question

NairManu-3755 avatar image
0 Votes"
NairManu-3755 asked NairManu-3755 commented

A warning prompt appears showing "RunOnStartup" is enabled for one of our azure functions.

In the "Diagnosis and solve problem" tab of our function app, a risk alert is showing as "RunOnStartup" is enabled for one of our azure functions.
But the parameter is already set as false when we check from "Code + Test" window. Not sure why the warning appears. Could you please help?

132662-runonstartup.png





132654-codetest.png


azure-functions
runonstartup.png (91.8 KiB)
codetest.png (38.1 KiB)
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I'm waiting for a reply to this question.
We have noticed unscheduled execution of this timer function and confirmed that it not due to "past due" execution.

So need to identify the root cause. The warning prompt says that "RunOnStartUp" is enabled, but it is false as I detailed before.

0 Votes 0 ·

@NairManu-3755 Apology for the delay and for any inconvenience with this issue. Can you please confirm if you still observe the same warning?

0 Votes 0 ·
NairManu-3755 avatar image NairManu-3755 MayankBargali-MSFT ·

@MayankBargali-MSFT Yes, the warning is still showing in the Azure portal.

0 Votes 0 ·

1 Answer

MayankBargali-MSFT avatar image
0 Votes"
MayankBargali-MSFT answered NairManu-3755 commented

@NairManu-3755 I was able to reproduce the issue and it is logging a warning if the “runOnStartup” setting is present, regardless of its actual value. I have engaged my product team and they are looking into it and will be fixing the issue the warning issue.

I will update my answer once the issue will be fixed.

· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@MayankBargali-MSFT : So is that a false warning?

0 Votes 0 ·

@NairManu-3755 Yes this is the false warning if your runOnStartup is already set to false in the function.json for your function.

1 Vote 1 ·

@NairManu-3755 The issue should be fixed now. Can you please verify and confirm if you are still observing the warning for runOnStartup.

0 Votes 0 ·
Show more comments