question

DhoDelo-3419 avatar image
0 Votes"
DhoDelo-3419 asked AnnaXiu-MSFT commented

A Setup package is either missing or damaged - VsHub_Core.msi

i am trying to install visual studio 2015 with update 3 on windows 7 ultimate
it shows error that "A Setup package is either missing or damaged - VsHub_Core.msi"
i tried on download package from the internet but it didnt worked.

vs-setupwindows-7-application-hardware-compatibility
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

May I know if you have got any chance to check the answers? I am glad to help if you have any other questions.

0 Votes 0 ·
AnnaXiu-MSFT avatar image
0 Votes"
AnnaXiu-MSFT answered AnnaXiu-MSFT edited

Hi @DhoDelo-3419 ,

Welcome to Microsoft Q&A!

Please check the Visual Studio 2015 system requirements and update your Windows 7 with the latest Windows Updates.

Meanwhile, please view the document: UPDATE: SHA-1 signed content to be retired.

On April 26, 2021, Visual Studio 2015 and older web installer files were removed from the Microsoft Download Center. These products can be installed from ISO images available at Downloads - Visual Studio Subscriptions Portal.

It shows that you can’t install it from online web installer. Please search “Visual Studio 2015 with Update 3” and select “DVD” file to run it as administrator.

Sincerely,
Anna


If the answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

LimitlessTechnology-2700 avatar image
0 Votes"
LimitlessTechnology-2700 answered

Hi there,

I suppose your download might be incomplete or the PC is not updated.
You can check the system requirements from here
https://docs.microsoft.com/en-us/visualstudio/productinfo/vs2015-sysrequirements-vs#--visual-studio-2015
Meanwhile, there is also a thread where the problem has been solved for the same issues and might be helpful for you
https://social.msdn.microsoft.com/Forums/en-US/889ecfb6-3916-497f-a11a-56b8e9dc1837/a-setup-package-is-either-missing-or-damaged-vshubcoremsi?forum=vssetup


Hope this answers all your queries, if not please do repost back.
If an Answer is helpful, please click "Accept Answer" and upvote it : )

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.