question

Panzera-9635 avatar image
1 Vote"
Panzera-9635 asked ErikDSnowden-2876 commented

Remote desktop can't connect to the remote computer for one of the reasons

Hello all!
Hope you are well.

In my client's network, we have 3 windows 10 pro PCs. He used to connect to his PC in his office room from either of the other 2 in the building via remote desktop. That was until yesterday where the pc installed the kb5005565 update.

After the update, he went along with his day and tried to connect to the office PC but it returned the following message:

133299-screenshot-2021-09-19-134145.png



The strange thing is that he can control the other 2 PCs from his and the other 2 can connect fine with each other!

I tried and read everything (turn off the firewall, change the port for RDC, change the port to decimal, check services, policies, check hosts, check ping, check if it was allowed through the firewall, and more...) recommended as solution to no avail. I even unistalled the update but the problem persists.

I am literally one step from going crazy here. i can't find what is wrong all the sudden and i do not know what else to try so i can help him.

There is no file server or any server on the network. Roughly the network is composed by the isp router where 3 switches are connected (1 in each pc room), only having a PC and printer connected on them.

I would appreciate any assistance.

Thanks in advance.

remote-desktop-serviceswindows-10-networkremote-desktop-client
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I have the same problem since this update. However removing the update does not solve the problem.

0 Votes 0 ·

I also have this problem after kb5005565. It is not affecting all of our users just some. Uninstalling the update did not solve the problem. Sometimes you can log in via RDP but then you can't click on anything or it disconnects. Is there a fix?

0 Votes 0 ·
DSPatrick avatar image
0 Votes"
DSPatrick answered DSPatrick commented

Try PowerShell from source and target. (use target address in both cases) post results

Test-NetConnection -ComputerName "192.168.49.142" -CommonTCPPort "RDP" -InformationLevel "Detailed"


· 14
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Just checking if there's any progress or updates?

--please don't forget to upvote and Accept as answer if the reply is helpful--






1 Vote 1 ·

Hello @DSPatrick and thanks for the answer.

We run it to all pcs and the results are as follows:

WARNING: TCP connect to host:port failed.

RemotePort: 3389
IsAdmin: False
PingSucceeded: True
PingReplyDetails (RTT): 0 ms
TcpTestSucceeded: False

On every pc is the same. Would you like to post the photos as well?

Thanks once more.

0 Votes 0 ·

Yes, post the complete result from source and target. (using target address in both cases)


0 Votes 0 ·
Show more comments
LimitlessTechnology-2700 avatar image
0 Votes"
LimitlessTechnology-2700 answered Panzera-9635 commented

Hello,

Thank you for your question.

I would like to suggest you to check below Troubleshooting steps.

  1. If you think its due to KB5005565 then uninstall it to see if you are able to get back to RDP.

  2. Please try to run port query tool from Microsoft if the if you are able get thru RDP port
    https://www.microsoft.com/en-in/download/details.aspx?id=24009

  3. Please check if all three PCs are in same network and same subnet or try to give same IP range for all of them to narrow down the issue.

  4. Please cleanup C:\Windows\Temp and C:\WinNT\Temp


If the reply was helpful, please don’t forget to upvote or accept as answer.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello and thanks for the prosped solution. i checked everything and did everything but stll dont work.

I tried to manually start the service (as recommended by DSPatrick above) and got return the below error:

133948-untitled1.png




Is it fixable in anyway?

0 Votes 0 ·
untitled1.png (47.1 KiB)
cthivierge avatar image
0 Votes"
cthivierge answered Panzera-9635 commented

Can you validate on the destination computer that the value fDenyTsConnections is set to "0"

reg query "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v fDenyTSConnections

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello.

Yes it is set to "0"

0 Votes 0 ·