question

baranidaran-7029 avatar image
0 Votes"
baranidaran-7029 asked baranidaran-7029 commented

Error accessing blob storage with SAS token


Hi Team,

need your assistance for the following scenario

Usage:
I have a webapp which has a functionality that allows user to upload files to the Azure blob storage and access the same file using the blob url.
I have opted for "Selected networks only" to access the storage account. Im using SAS token to upload the file. Upload operation is handled through APIM its IP is configured in VNET
with the same blob url returned after uploading the file the user needs to access the file.

Expected:
After uploading the file blob url will be returned with SAS as suffix, by clicking the url user should be able to download the file.

Error:
By clicking on the URL user not able to access the file instead getting an error "This request is not authorized for this operation"

Parameters used in SAS:
Services
ResourceTypes
Permissions
Protocols
Expiry
IPrangeorAddress

Note:
User is able to access the file using the url once user public ip is added to the selected network tab. This is not possible in our case as the users will be accessing the file dynamically and cannot be preconfiguring their IPs in storage account always





azure-storage-accountsazure-blob-storage
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@baranidaran-7029 Can you regenerate the SAS token and try again! Let me know the status!

Looking forward for your reply!

0 Votes 0 ·

@Sumarigo-MSFT I
have tried regenerating SAS token several times, it didnt work
unless i add ip to network tabs im getting the same error

0 Votes 0 ·

Hi, Any updates on this?

0 Votes 0 ·

0 Answers