question

stefanosevangelou avatar image
0 Votes"
stefanosevangelou asked BruceZhang-MSFT commented

Does Azure App Service support ASP.NET 4.6.1 version?

I need to deploy n ASP.NET 4.6.1 application into Azure App Service. Currently only ASP.NET 3.5 and ASP.NET 4.8 seem to be available options in the Azure portal. Is this a hard requirement, i.e. is it mandatory to update my ASP.NET solutions to 4.8 version prior to deploying to Azure App Service?

dotnet-aspnet-generalazure-webapps-development
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

ryanchill avatar image
0 Votes"
ryanchill answered BruceZhang-MSFT commented

Hi @stefanosevangelou,

You should be fine deploying your 4.6.1 app to ASP.NET 4.8 runtime app service instance as .NET v4.x are backwards compatible. Have a look at https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/version-compatibility, but should you run into issues, https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/retargeting/4.6.1-4.8 should help direct you to correcting any issues.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @stefanosevangelou ,

You don't need to update asp.net application to 4.8 version. Azure serivce has announced support for asp.net 4.6 version six years ago.

And for a long time, asp.net version updates are backward compatible, that is, the latest version will be as compatible as possible with the functions of the old version.

You can deploy asp.net application to Azure service directly.



If the answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our  documentation  to enable e-mail notifications if you want to receive the related email notification for this thread.


Best regards,
Bruce Zhang


0 Votes 0 ·