question

SAMUELVALAPARLA-3110 avatar image
0 Votes"
SAMUELVALAPARLA-3110 asked SAMUELVALAPARLA-3110 commented

PXE Boot failing with Error code 0xc0000001

Hi.

We're running MEM 2010

When trying to build some machines at a site, we're continuously running into the error attached .

133539-wds-pxe-error-01.png



As per some solutions advised we've tried to change the TFTP block size and also disabled the Variable Window Expansion option (steps below)

  1. Open the WDS console, right click on the server then click on Properties

  2. Go to the TFTP tab, block size enter 4096 or more

  3. Uncheck Enable Variable Window Expansion and click Apply

  4. Restart WDS service

But we've not seen any change. We're not configuring WDS anywhere specifically, but instead it's being controlled by SCCM. Next option, we're considering is to find if there's any DHCP Snooping that's happening and then to disable the same.

Kindly advise if anything else can be done.



mem-cm-osd
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

AllenLiu-MSFT avatar image
0 Votes"
AllenLiu-MSFT answered SAMUELVALAPARLA-3110 commented

Hi, @SAMUELVALAPARLA-3110
Thank you for posting in Microsoft Q&A forum.

Error 0xC0000001 is related to some problem/conflict between TFTP and the network adapter of the machine you're imaging, here are some link in below article that you may try, such as:
Update send and receive buffers
Update the registry key of "RamDiskTFTPBlockSize" from 16384 to 1456
reinstall WDS

And if the issue occurs on a specific model of computer, you may need to add the network adapter driver to the boot image.
For more details, please refer to the article:
https://www.consentfactory.com/quickie-pxe-0xc0000001-error-in-sccm/
(Please note: Information posted in the given link is hosted by a third party. Microsoft does not guarantee the accuracy and effectiveness of information.)


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@AllenLiu-MSFT , thank you very much for getting back on this query. We had tried performing all of the suggested steps but the issue still persists. Same error and code 0xc0000001

  • Update send and receive buffers

  • Updated the registry key of "RamDiskTFTPBlockSize" to 1456 (it is 4096 across the board)
    Reinstall WDS

Also this issue occurs on multiple models of machine. We have already added the relevant network adapter drivers to the boot image.

We may need to enable port mirroring and trace the connection flow, handshakes etc. The strange thing is that things were working fine at this location about 10 days ago. But this seems entirely broken now and we're unable to Image computers.

0 Votes 0 ·
AllenLiu-MSFT avatar image AllenLiu-MSFT SAMUELVALAPARLA-3110 ·

It’s strange that the common solutions for code 0xc0000001 don’t work for you, is there any progress about this issue?

0 Votes 0 ·

Hi @AllenLiu-MSFT Indeed it's strange that the common solutions did not work. We've opened a ticket with MS and they're trying to analyse this further. Hope to come back once we have some findings.

0 Votes 0 ·