question

VivekRamesh-0096 avatar image
0 Votes"
VivekRamesh-0096 asked YuZhou-MSFT commented

"nomerge" behavior not working in MsEdge browser v93 with IE Mode

Hi All,

I try to prevent session sharing between different windows/tabs of Edge browser v93 (latest version).

1) I'm using "-nomerge" in VBScript to launch my application as below

 AppToLaunch = "msedge -nomerge --new-window --app=" & "http://servername/index.aspx"
    
 dim WshShell
 set WshShell = WScript.CreateObject("WScript.Shell")
 WshShell.Run AppToLaunch

2) I have done some settings to launch my application in IE Mode when I opened it via VBScript or Entering URL in Edge browser

3) Configured the below setting in the integrated site list manager tool available at "edge://compat/sitelistmanager"

 <site-list version="x">
 <site url="http://serverName/index.aspx">
 <compat-mode>IE11</compat-mode>
 <open-in merge-type="no-merge">IE11</open-in>
 </site>
 </site-list>

Still, the sessions between different tabs/windows are getting merged in the Edge browser. Could anyone please help me to resolve this?

Thanks in advance,

ms-edge
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @VivekRamesh-0096

From the doc, the command line for no-merge mode should be --enable-features=msAllowNoMergeIEMode.
Have you tried to use this in your VBScript to launch Edge? You can try to use this and tell us about your test result.

0 Votes 0 ·

Hi @YuZhou-MSFT,

Thanks for your response.

Since I'm using the MSEdge v93, I haven't used --enable-features=msAllowNoMergeIEMode.

As per your suggestion, I have updated the VBScript as below

 AppToLaunch = "msedge --new-window --enable-features=msAllowNoMergeIEMode --app=" & "http://servername/index.aspx"

but there is no change in the result. Still, I'm facing the same issue

0 Votes 0 ·
YuZhou-MSFT avatar image YuZhou-MSFT VivekRamesh-0096 ·

Hi @VivekRamesh-0096

I followed the steps in the doc and test with Edge version 94.0.992.31, the no-merge mode works fine.
Have you enabled IE mode first using group policies? I tested and found that we need to enable IE mode according to this doc, otherwise no-merge mode won't work in IE mode.
Besides, please pay attention that no-merge mode only works in different IE mode windows, it won't work between tabs.

0 Votes 0 ·

0 Answers