question

HobackJacob-4417 avatar image
0 Votes"
HobackJacob-4417 asked asergaz commented

How should network be configured to allow physical device to connect to IoT Hub?

Hello all,

I have a physical device which is attempting to connect to IoT Hub using MQTTS protocol (port 8883). I am working within a corporate network environment, so I cannot have port 8883 left open. IT department is asking for source and destination IP addresses to allow a connection from the device to IoT Hub. I am able to set a static IP address for the device I am setting up, but I am unsure if I have given IT the proper information for my IoT Hub. I thought that according to Microsoft documentation
the destination should be set in the format myhub.azure-devices.net. I relayed this information to IT, and they claim to have done this, but I still have not had any luck with connecting the device to my IoT Hub. Is there something I am missing here? Does the port have to be left completely open? Any thoughts or advice is greatly appreciated.


azure-iot-hub
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

asergaz avatar image
0 Votes"
asergaz answered asergaz commented

Hi @HobackJacob-4417 ,
Is the IT department enabling Outbound rules for the Azure IoT hub hostname (myhub.azure-devices.net) on port 8883 ? You can also try setting the IP Address from IoT Hub instead - using the service tags JSON file.

For example, these are current IP addresses for WestEurope

 "name": "AzureIoTHub.WestEurope",
       "id": "AzureIoTHub.WestEurope",
       "properties": {
         "changeNumber": 1,
         "region": "westeurope",
         "regionId": 18,
         "platform": "Azure",
         "systemService": "AzureIoTHub",
         "addressPrefixes": [
           "13.69.71.0/25",
           "13.69.109.0/25",
           "13.95.15.251/32",
           "23.100.4.253/32",
           "23.100.8.130/32",
           "40.113.153.50/32",
           "40.113.176.160/27",
           "40.113.176.192/27",
           "40.113.177.0/24",
           "40.118.27.192/32",
           "51.144.118.31/32",
           "52.236.189.128/25",
           "2603:1020:206:402::300/123",
           "2603:1020:206:802::240/123",
           "2603:1020:206:c02::240/123"
         ],



· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello @asergaz,

Thank you for the response. I will be attempting to get in touch with IT security to see what they actually did. Thank you for that link to the service tags, I was able to find the information needed and will pass that along to IT as well.

1 Vote 1 ·
asergaz avatar image asergaz HobackJacob-4417 ·

Hi @HobackJacob-4417 following-up to check if you were able to connect to IoTHub ?

Thanks for sharing the results in advance :)!

Remember:
- Please accept an answer if correct. Original posters help the community find answers faster by identifying the correct answer. Here is how.
- Want a reminder to come back and check responses? Here is how to subscribe to a notification.


0 Votes 0 ·