question

AhmedDeban-2266 avatar image
0 Votes"
AhmedDeban-2266 asked AhmedDeban-2266 commented

SCCM 2012 Console unable to application deploy for the clients

Dears ,

I am try to deploy some application for the clients by SCCM console the distribution point is successfully distributed the package but the clients No mandatory Enforce tasks. No actions performed:

For your information remote control is working fine but the troubles in the Application Deployments As I checked


No mandatory Enforce tasks. No actions will be performed as I checked C:\Windows\CCM\Logs\CIAgent : "Internal Request to delete CIAgent job-Internal Request to delete CIAgent job " and "No mandatory Enforce tasks. No actions will be performed"

Thanks

mem-cm-application
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Amandayou-MSFT avatar image
0 Votes"
Amandayou-MSFT answered

Hi @AhmedDeban-2266,

We could notice if the client receives the policy from the server. Please check PolicyAgent.log, it tells the client that it have stuff to do.

And AppDiscovery.log will check if the application is already installed. If not, ContentTransferManager.log will check who should download the content, AppEnforce.log will monitor install the application.

Here is the article about how to track an installation through client log-files:
https://deploymentparts.wordpress.com/2015/08/14/how-to-track-an-installation-through-client-log-files/
Note: Non-Microsoft link, just for the reference.



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

AhmedDeban-2266 avatar image
0 Votes"
AhmedDeban-2266 answered AhmedDeban-2266 commented

Hi @Amandayou-MSFT

I checked all the logs the client is not get any application there some problem with application deployment, As I mentioned previous the distribution point and remote tool is fine but the issue in the deployment application before 15-09-2021 is working good but after that some issues happen and we need to troubleshoot why this log happen maybe cause this issue No mandatory Enforce tasks. No actions will be performed as I checked C:\Windows\CCM\Logs\CIAgent : "Internal Request to delete CIAgent job-Internal Request to delete CIAgent job " and "No mandatory Enforce tasks. No actions will be performed"

---------------------------------------------- checked ------------------------------------------------------------------
PolicyAgent.log:Received User delta policy update with 0 assignments \\ No error we can reach the server site .
AppDiscovery.log :this log is not generate yet cause unable to deploy any application and this my problem.
ContentTransferManager.log : Not reporting any download events to server. No recent downloads found .

by the way thanks for your tried

AppEnforce.log ::this log is not generate yet cause unable to deploy any application and this my problem.

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,

According to the information, it seems the client has not received the policy. We could find the unique ID on the side of console, the same goes for the ScopeId_, DeploymentType_ and revision part. And then check if there is the unique ID in the policyagent.log.

Best regards,
Amanda

0 Votes 0 ·

Hi @Amandayou-MSFT

Have a nice day,

As I checked the Policyagent.log, it's show up the unique ClenitID , as shown below :
Raising event:
instance of CCM_PolicyAgent_AssignmentsReceived
{
AuthorityName = "SMS:RHO";
ClientID = "GUID:FFA6E63E-AA8D-4F4F-849F-5D8FF6DD7FF2";
DateTime = "20210926051959.994000+000";
ProcessID = 3204;
ReplyType = "Delta";
ResourceName = "S-1-5-21-255093205-3874505116-2399341845-14742";
ResourceType = "User";
ThreadID = 12912;
};
PolicyAgent_RequestAssignments 9/26/2021 8:19:59 AM 12912 (0x3270)

0 Votes 0 ·
AhmedDeban-2266 avatar image
0 Votes"
AhmedDeban-2266 answered AhmedDeban-2266 commented

Hi @Amandayou-MSFT ,

After disable prompt for remote control permissions it's solved and the applications installed ,but there issue with the remote access permissions it's not apprearing approval or deny after disabling this option :/ ,

135259-image.png





Thanks to you


image.png (45.2 KiB)
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,

Based on my experience, it seems there is no direct relationship between remote control and application installation. It is needed to compare CAS logs in this client and normal client to find if the application is installed successfully.

Best regards,
Amanda

0 Votes 0 ·

Dear @Amandayou-MSFT You maybe right but when do No the deployment successfully done ,when Yes it's stuck for whole , By the way thanks to you for supporting me


135749-image.png


0 Votes 0 ·
image.png (2.4 KiB)