question

cece-5030 avatar image
0 Votes"
cece-5030 asked ErlandSommarskog commented

SQL Server feature Database Engine Services failed to install

Hi,

So, I'm trying to install SQL Server 2019 Developer Edition (the Custom install) and I chose to install the features Database Engine Services, Analysis Services and Integration Services. Everything succeeded except for the Database Engine Services.

134738-error1.png

134776-error2.png

First the error code that I got was 1722, and because I'm very bad at reading logs, here are summary.txt and detail.txt regardind the error.

134778-summary.txt

134740-detail.txt

Tried to repair the issue with Maintenance from SQL Server Installation Center, also restarted Windows Installer from Services.msc and reregistered the Windows Installer with msiexec /unregister and msiexec /regserver commands.
After restarting the computer, I then tried to add the Database Engine Services feature to my previous installed environment. An error occured again. A different one this time, with the error code 0xe80004005.
134777-error3.png

134792-error4.png


You have summary.txt and detail.txt regarding this error too.

134821-summary.txt

134706-detail.txt

I tried to install SQL Server 2017 just to see if the error had to do with he version, but the result was the same.
I'm using a virtual machine running windows 11 (also tried with Win10 and the error are the same) with nothing else installed, so no previous SQL Server installations were made before this.
Can please, someone help me? Thank you.


sql-server-general
error1.png (122.2 KiB)
error2.png (154.8 KiB)
error3.png (181.0 KiB)
error4.png (130.7 KiB)
summary.txt (9.7 KiB)
detail.txt (312.9 KiB)
summary.txt (8.7 KiB)
detail.txt (2.3 MiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

cece-5030 avatar image
0 Votes"
cece-5030 answered ErlandSommarskog commented

AmeliaGu-msft shared a Parallels forum thread with a solution that worked for me.

Here is what I did:

  • I had to use Windows 10 Build 21376 (the one I had tried before was a different and more recent build, but couldn't get it to work).

  • Installed SQL Server. The Database Engine Services feature failed to install, but not to worry.

  • Downloaded and run Cumulative Update Package 12 for SQL Server 2019 - KB5004524.

  • Installed SQL Server again, this time just to add the missing feature in the same instance previously created.

And that was it. The installation was a success!
I could also install, without trouble, SQL Server Management Studio, Visual Studio and Power BI Desktop, and all seems to work perfectly.

Thank you all for the help!

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Wow! That was a bit work! Glad to hear that you got it sorted out!

0 Votes 0 ·
AmeliaGu-msft avatar image
0 Votes"
AmeliaGu-msft answered cece-5030 commented

Hi cece-5030,

Welcome to Microsoft Q&A.
Could you please try to download and install SQL Server again from official website? The installation package you are using may be corrupted.
In addition, please remove previous failed installation clearly using the steps in this link.
Please make sure you right click on setup.exe file and select run as administrator when you want to start the SQL Server installation. And disable any antivirus/security software and turn off firewall on the machine for the time that the installation is running.

Best Regards,
Amelia


If the answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi Amelia,

Thank you but still, I'm getting the same error. All installation tries I do are like new ones, because I install a new virtual machine everytime to make sure.
I disabled everything and went on getting another official SQL Server download setup from the website just like you said, but the error 1722 remains.

Is it something to do with server and user account permissions (read somewhere that changing that can be a solution)?

135005-serverconfiguration.png


135055-databaseengineconfiguration.png


134988-analysisservicesconfiguration.png


0 Votes 0 ·
ErlandSommarskog avatar image
0 Votes"
ErlandSommarskog answered cece-5030 commented

No, I don't think the account settings has anything to do with it.

I looked at these logs last night, but I did not post anything, because I felt that I did not have that much useful to add.

It seems like the problem is that a number of MSI files are missing, and I guess that's why Amelia thinks that the the download is corrupted. I am not sure that this is the case, but you could try the download from a computer, in case there is something that distorts the download.

You say that you install a new VM each time, but I suppose that VM is installed from the same template?

Am I right to assume that you are in a corporate environment?

My hinch is that there is some anti-malware software active at your site that eats parts of the files the the install needs. But that is just a hinch, and I may be plain wrong.

· 6
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Well I'm on a Macbook Air with an M1 processor which means that if I want to run a Windows virtual machine, I need to install Parallels (there are are other options, but this is what I did) and then download Windows 11 on ARM from Windows Insider Preview. I'm sorry if I was not clear about that before.
I have installed other software and applications (Anaconda and Visual Studio for example) and they worked fine. I'm only having issues with SQL Server. Maybe SQL Server is not compatible with windows 11 yet? But I also tried on a windows 10 ARM build and the problem was the same, so maybe it's not that.

Is it the Windows 11 download that somehow got corrupted? Is it the Parallels installation?

I usually don't have problems using VirtualBox VMs for example, but I'm new to macOs and ARM builds, and Parallels works differently...
I just need to use SQL Server Database, SQL Server Management Studio (that also installs just fine), Visual Studio and Power BI, and I refuse to believe that because I have an M1 Mac, it won't work. It's more likely that I am doing something wrong, or better yet, I'm forgetting something...

I'm sorry for the rant. Thank you very much. I appreciate all the help you can give me.

0 Votes 0 ·

Maybe SQL Server is not compatible with windows 11 yet?


Windows 11 did not exist when SQL Server 2019 was released, so obviously the SQL Server setup cannot know about it. So rather the question is "Maybe Windows 11 is not compatible with SQL Server yet?".

I have not played with Windows 11 myself, so I cannot say whether SQL Server installs on it. But it certainly sounds like you are an unsupported platform.

0 Votes 0 ·
cece-5030 avatar image cece-5030 ErlandSommarskog ·

Maybe SQL Server is not compatible with ARM architecture, wether it being an 11 or 10 version of windows. I'll keep trying to find a solution. Thank you!

0 Votes 0 ·
Show more comments