question

palmerjay-3948 avatar image
0 Votes"
palmerjay-3948 asked deherman-MSFT commented

Why do I not see Encryption at host as an option?

Hi all.
I have enabled encryption at host using the following command:
egister-AzProviderFeature -FeatureName "EncryptionAtHost" -ProviderNamespace "Microsoft.Compute"

After a few minutes i run:
Get-AzProviderFeature -FeatureName "EncryptionAtHost" -ProviderNamespace "Microsoft.Compute"

And i get this:
FeatureName ProviderName RegistrationState


EncryptionAtHost Microsoft.Compute Registered

But, when i go to deploy a VM in teh subscription, i don't see the option to select 'encryption at host' as it shows in the doc:
https://docs.microsoft.com/en-us/azure/virtual-machines/disks-enable-host-based-encryption-portal

What am I missing? Why can't i chose the option. Any ideas welcome.

azure-disk-encryption
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

deherman-MSFT avatar image
0 Votes"
deherman-MSFT answered

@palmerjay-3948
You need to sign into the portal with a specific link. Encryption at host is not currently visible in the public Azure portal without using the link. Also make sure you are using a supported VM.

Please try the link and see if it works for you. If you are still facing issues please let us know and we can continue to investigate.

https://aka.ms/diskencryptionupdates



Please don’t forget to "Accept the answer" and “up-vote” wherever the information provided helps you, this can be beneficial to other community members.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.