question

melonNG-6986 avatar image
0 Votes"
melonNG-6986 asked BruceZhang-MSFT commented

Site crashes with fatal communication error.

My site runs on IIS 6.2(windows server 2012) with asp.net core 6 RC1

The application pool of my site strangely automatically stop.

From the event viewer, I found it reports these warnings:
A process serving application pool 'aaa.com' suffered a fatal communication error with the Windows Process Activation Service. The process id was '4592'. The data field contains the error number.
A process serving application pool 'aaa.com' suffered a fatal communication error with the Windows Process Activation Service. The process id was '6808'. The data field contains the error number.
A process serving application pool 'aaa.com' suffered a fatal communication error with the Windows Process Activation Service. The process id was '3252'. The data field contains the error number.
A process serving application pool 'aaa.com' suffered a fatal communication error with the Windows Process Activation Service. The process id was '6496'. The data field contains the error number.

Then it reports this error and stops the application pool automatically:
Application pool 'aaa.com' is being automatically disabled due to a series of failures in the process(es) serving that application pool.

It seems this problem occurs after I upgrade my site from .net 5 to .net 6 RC1.

What's wrong with it? Thank you.

windows-server-iis-generaldotnet-aspnet-general
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @melonNG-6986 ,

Are you sure the version of IIS is 6.2? The default version of IIS on windows server 2012 is IIS8.5. Please check it again.

It is currently uncertain whether there is a compatibility issue between the different versions of .net 6 and IIS, because .net 6 has not been officially released and is still a preview version. It may be problematic.

You can try to set enable 32-bit applications of application pool to true and try again.
135337-3.jpg


0 Votes 0 ·
3.jpg (15.3 KiB)

I am sorry that my IIS is 8.5.9600.

Let me try to enable the 32-Bit Application.

However, I compiled my website Target Runtime as win-64. And also my windows server 2012 is a win-64 system. Will this work?

0 Votes 0 ·

Hi @melonNG-6986 ,

In most cases, this setting can solve this problem, so I suggest you try it first. If the solution does not apply to you, you need to use the debug tool to grab more detailed logs.

0 Votes 0 ·

0 Answers