question

JustinMicheal-7973 avatar image
0 Votes"
JustinMicheal-7973 asked JustinMicheal-7973 edited

UPDATE ISSUE

have two Windows Server 2016 servers for deploying Citrix servers from and the updates have stopped working.

office-itpro
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

emizhang-msft avatar image
0 Votes"
emizhang-msft answered emizhang-msft commented

Hi @JustinMicheal-7973,

"The keys before deletion appeared to point to a location on the C: drive, after deletion and recreated they point at a HTTP address." It seems the update path is set to local.
How did you install the Office? Did you use Office Deployment Tool run the configuration file?
If yes, I suggest you check if the configuration file set the UpdatePath attribute, you can modify the file to default UpdatePath and refer to this support article:
https://docs.microsoft.com/en-us/deployoffice/office-deployment-tool-configuration-options#updates-element

After setting to default path, if you install with ODT and configuration file next time, the Office will update without problem.


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

The config file I used is as below :-

<Configuration>

<Add Sourcepath=\\ukfhisi.uk.experian.local\AppVRepo\Server Installation\MS Office 365 x86 OfficeClientEdition="32" Channel="Monthly">

 <Product ID="O365ProPlusRetail">

   <Language ID="en-us" />

   <ExcludeApp ID="Teams" />

   <ExcludeApp ID="Bing" />

 </Product>

 <Product ID="SkypeforBusinessRetail">

                 <Language ID="en-us" />

 </Product>

 <Product ID="VisioProRetail">

                 <Language ID="en-us" />

0 Votes 0 ·
 </Product>

 <Product ID="ProjectRetail">

                 <Language ID="en-us" />

 </Product>

</Add>

<Updates Enabled="TRUE" />

<Display Level="None" AcceptEULA="TRUE" />

<Logging Level="Standard" Path="%TEMP%" />

<Property Name="SharedComputerLicensing" Value="1" />

<Property Name="PinIconsToTaskbar" Value="TRUE" />

<Property Name="SCLCacheOverride" Value="0" />

<Property Name="AUTOACTIVATE" Value="0" />

<Property Name="FORCEAPPSHUTDOWN" Value="FALSE" />

<Property Name="DeviceBasedLicensing" Value="0" />

</Configuration>

Are there any changes I need to make ? This has been working for over a year with updates applying correctly, not sure why it suddenly stopped

0 Votes 0 ·
emizhang-msft avatar image emizhang-msft JustinMicheal-7973 ·

<Updates Enabled="TRUE" />
The configure.xml looks fine, do you set any disable settings in Citrix servers?
Try to you check the Office update manually, open Office application- go to File- Account- Update Options- Update Now.

0 Votes 0 ·