question

SoonJooGenting-3682 avatar image
0 Votes"
SoonJooGenting-3682 asked SnehaAgrawal-MSFT commented

Azure Web Apps Apache Settings

Hi,

I need to increase the value of LimitRequestLine in Apache settings, wonder how can I do this?

As I'm getting 414 error as the URL too long.

I am hosting using the Linux Web Service Plan.

Best regards,
Soon Joo

azure-webapps
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi.

What did you specify for the App Service on Linux runtime? (PHP7.4? PHP8? Or something else?) The web server changes depending on the runtime

0 Votes 0 ·

The PHP version we deployed was PHP7.4. How do i check what is the limit and how can I change the limit?

0 Votes 0 ·

1 Answer

TakahitoIwasa avatar image
0 Votes"
TakahitoIwasa answered

Hi.

With PHP7.4 you need to change the Apache settings.
https://httpd.apache.org/docs/2.4/ja/mod/core.html#limitrequestline

The following is an example of Nginx, but you can update the Apache configuration file in the same way during the initialization process of App Service.
https://dev.classmethod.jp/articles/app-service-linux-php-default-document/

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.