question

LongAlan-2913 avatar image
0 Votes"
LongAlan-2913 asked LongAlan-2913 commented

Can't open excel file on SharePoint Online

We have uploaded some excel files to a SharePoint Online library with IRM setting enabled. Recently we cannot open some of the files in the library. It said "You are not signed in to Office with an account that has permission to open this workbook. You may sign in a new account into Office that has permission or request permission from......"
135903-image.png

When I click "Add Account", it shows MS login page
135922-image.png

After I login my account, which is an owner account of this SharePoint site and library, it shows
135914-image.png

May I know how to solve this issue? Thanks.


office-sharepoint-onlineoffice-excel-itpro
image.png (35.6 KiB)
image.png (19.4 KiB)
image.png (11.9 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

EchoDu-MSFT avatar image
0 Votes"
EchoDu-MSFT answered LongAlan-2913 commented

Hello @longalan-2913 ,

Welcome to Q&A Forum!

This is expected behaviour. It occurs if you are trying to sign in using an Microsoft 365 account that is from the same organization as the Microsoft 365 account that is already logged in on your Computer or Office Desktop app.

Please following steps:

1.Sign out of the accounts (for the same domain) that are signed in, then restart that computer. If this solution does not resolve the issue, try the workaround below

2.Workaround: Remove the existing user account and all connected services from your Office profile, and then clear cached credentials that may be on the computer

Step1:Sign out of Office and then sign back in.

Sign out of Microsoft Office using any Office product: Word, Excel, PowerPoint, Outlook, etc.

  • 1.Select File, and then select Account.

  • 2.Select Sign out.

  • 3.Close the Office product and then restart it.

  • 4.Select File, and then select Account.

  • 5.Select Sign in and use your credentials to sign back in.

Step 2: Remove the user account from your Office profile

  • 1.On the upper-right corner of an Office app (Word, Excel, PowerPoint), select your name, and then select Switch Account.

  • 2.On the Accounts screen, select Sign out.

136112-1.png

  • 3.Locate the account that you want to remove, and then select Sign out.

Step 3: Remove connected services from your Office profile

  • 1.Go to File, and then select Account.

  • 2.Under Connected Services, remove all the services for the existing account.

136122-2.png

Step 4: Clear cached credentials on the computer

a.Edit the registry to remove cached credentials:

  • 1.Select Start, select Run, type regedit, and then select OK.

  • 2.On Registry Editor, locate the following registry subkey:

HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Identity\Identities

  • 3.Select the Office account that you want to delete, and then select Delete.

  • 4.On the Identity subkey, locate Profiles, right-click the same Office account that you located in Step 1 of this procedure, and then select Delete.

  • 5.Select File and then Exit Registry Editor.

b.Remove the cached credentials in Credentials Manager:

  • 1.Select Start, then Windows System, then open the Control Panel and select Credential Manager.

  • 2.Under the Windows Credentials tab, locate the account that you want to remove and then select Remove.

136060-3.png

  • 3.Log off, and then log back in to the computer.

Reference:

"Sorry, another account from your organization is already signed in on this computer" in Office 2013

Thanks,
Echo Du
=================================
If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.





1.png (14.0 KiB)
2.png (9.1 KiB)
3.png (33.1 KiB)
· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi Echo,

Thanks for the support. After I follow the steps the excel files on SharePoint online still cannot be opened and display the same notification "You are not sign in to Office..."

0 Votes 0 ·

Hi @longalan-2913 ,

Please perform the following troubleshooting:

  1. Does this excel file have unique permission, so you don’t have permission to the file.

  2. If you upload the excel file to another document library that has not set the IRM settings, will the problem occur if you receive it?

  3. Will the problem also occur when opening file through "Excel Online"?

Thanks,
Echo Du



0 Votes 0 ·

Hi,

I've checked the file permission and I should have owner permission for in on SPO.

I tried to upload it to another document library without IRM and it occur the same problem.

When open with browser in the original library, it could be opened but it cannot be changed to editing mode. If open the file in another library, it cannot open with browser.

0 Votes 0 ·

@longalan-2913 ,

Is there any progress on this issue?

Please feel free to reply.

0 Votes 0 ·

Hi,

  1. I've checked the file permission and I should have owner permission for in on SPO.

  2. I tried to upload it to another document library without IRM and it occur the same problem.

  3. When open with browser in the original library, it could be opened but it cannot be changed to editing mode. If open the file in another library, it cannot open with browser.

0 Votes 0 ·