question

Icefoxz avatar image
0 Votes"
Icefoxz asked GitaraniSharmaMSFT-4262 commented

CDN endpoint not recognize my DNS record when setting custom domain.

136580-20210930170433.png


136614-20210930170441.png


136661-20210930170422.png



Hi there. I created a static website suggested by documentation https://docs.microsoft.com/en-us/azure/storage/blobs/storage-blob-static-website and https://docs.microsoft.com/en-us/azure/storage/blobs/storage-custom-domain-name?tabs=azure-portal to map my website to the domain that I brought pass few months ago. But I'm now stuck on the custom domain step, I can't add my www CNAME record set due to the CND endpoint could not find my records.

Thank to anybody who might have some advice.

azure-dnsazure-cdn
20210930170433.png (21.8 KiB)
20210930170441.png (4.8 KiB)
20210930170422.png (39.1 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

GitaraniSharmaMSFT-4262 avatar image
0 Votes"
GitaraniSharmaMSFT-4262 answered GitaraniSharmaMSFT-4262 commented

Hello @Icefoxz ,

Welcome to Microsoft Q&A Platform. Thank you for reaching out & hope you are doing well.

As per the doc, to create a CNAME record for your custom domain & map it to the temporary cdnverify sudomain, you need to create an entry as below:

136656-image.png

So, in your case, it would be as follows:

Source: Enter your custom domain name, including the cdnverify subdomain, in the following format: cdnverify.<custom-domain-name>
Which is : cdnverify.www.mota.com
Type: Enter or select CNAME.

Destination: Enter your CDN endpoint hostname, including the cdnverify subdomain, in the following format: cdnverify.<endpoint-name>.azureedge.net.
Which is : cdnverify.mota.azureedge.net

It should look like :

136674-image.png

But from your screenshot, it looks like you have mapped it incorrectly.

136599-image.png

Please edit the CNAME and map it to the your custom domain correctly for it to be validated, post which you should be able to add your custom domain to your CDN endpoint.

Kindly let us know if the above helps or you need further assistance on this issue.


Please "Accept the answer" if the information helped you. This will help us and others in the community as well.



image.png (5.2 KiB)
image.png (8.6 KiB)
image.png (3.1 KiB)
· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi GitaraniSharma,
Thanks for your response. This cdnverify.www is created automatically when I create a www alias to my CDN resource. Here is the detail page that showed it mapped correctly.136740-20211001094715.png


0 Votes 0 ·
20211001094715.png (13.1 KiB)

Hello @Icefoxz ,

Thank you for the update.

May I know if this custom domain is mapped to any other existing CDN endpoint or is this the first time you are setting it up?

Also, from the screenshot that you provided, it looks like you are using Azure DNS to host your custom domain. Did you sucessfully delegate your custom domain to Azure DNS?

Azure DNS isn't a domain registrar. Azure DNS allows you to host a DNS zone and manage the DNS records for a domain in Azure. In order for DNS queries for a domain to reach Azure DNS, the domain has to be delegated to Azure DNS from the parent domain.
Please refer : https://docs.microsoft.com/en-us/azure/cdn/cdn-map-content-to-custom-domain?tabs=azure-dns%2Cazure-portal%2Cazure-portal-cleanup#prerequisites
https://docs.microsoft.com/en-us/azure/dns/dns-delegate-domain-azure-dns

Regards,
Gita Sharma

0 Votes 0 ·
Icefoxz avatar image Icefoxz GitaraniSharmaMSFT-4262 ·

Hi GitaraniSharma,

Thanks for your follow-up.

I think I know the problem. Well, this is not the first time I set up a CDN endpoint. But this is the first time I have encountered such a problem.

I thought that once I had the Azure DNS instance, mota.com would belong to me. But in this case, I haven't owned this domain name yet.

Thank you.

0 Votes 0 ·
Show more comments