question

00chrispierce00 avatar image
0 Votes"
00chrispierce00 asked LeonLaude commented

SCOrch 2019 - Orchestrator Runbook Service account

A few months back, I installed SCOrch 2019 onto a server (both the management server piece and the runbook server piece).

Yesterday, I changed the service account used for the Orchestrator Runbook Service. Now, runbooks will not run when triggered by Service Manager 2019 workflows.

I have verified that the new service account is a local admin on the server, and it has been added to 'Logon as a Service' within local security policy.

Any ideas why runbooks aren't running?


thank you,
Chris





msc-orchestrator
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

LeonLaude avatar image
0 Votes"
LeonLaude answered LeonLaude commented

Hi @00chrispierce00,

You update the Orchestrator service account by going to the Services.msc and there search for the Orchestrator services and change the account.

137657-orchestrator-services.png

In addition to that, you must also change the account in the Application Pool "System Center 2012 Orchestrator Web Features" with IIS Admin.

If you specified Windows Authentication to Orchestrator Database during setup (default and recommended), the new Account must have a login in the Database Orchestrator Database or the SQL Instance, and be a member of the SQL-Roles:

  • Microsoft.SystemCenter.Orchestrator.Admins

  • Microsoft.SystemCenter.Orchestrator.operators

  • Microsoft.SystemCenter.Orchestrator.Users



If the reply was helpful please don't forget to upvote and/or accept as answer, thank you!


Best regards,
Leon


· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thank you LeonLaude.

I followed your steps to update the new service account in SQL and IIS Application Pool.

There was one additional place I had to update before the runbooks would start working:

"Orchestrator System Group" within 'Local Users and Groups - Groups'.

Everything is working now.

Thanks again!

Chris

0 Votes 0 ·
LeonLaude avatar image LeonLaude 00chrispierce00 ·

Glad to hear you got it working!

0 Votes 0 ·