question

RolandPisano-7376 avatar image
0 Votes"
RolandPisano-7376 asked RolandPisano-7376 edited

FSLogix randomly can't rename a file inside an user profile

Hi,
Fresh install of a new RDS Farm with FSLogix on Windows Server 2019.
We use an application based on Prism, an old Mozilla tool.
This application Works perfectly on our old RDS farm based on Windows Server 2012R2, wich uses simple VHDX users profile (not FSLogix).
First user logs in and launches the application. It displays correctly.
Second user logs in in the same RDS server, same result.
Then another one and so on.
Then randomly, an user logs in, launches the application. It displays only a white page.
Then, all the following users logging in has the same result : white page.
It needs between 10 and 20 connections on the same RDS server to get that result.
A previous user (not impacted by the bug) can log off and log in again, the display is correct.
The only way to correct the bug is to reboot the RDS server or to play with the broker to allow the user to log in another RDS server.

If the user is part of the "FSLogix Profile Exclude List", the bug is not happening.

I have updated FSLogix Client from 2.9.76.34 to 2.9.78.38 but the bug is still here.

In the %appdata% of the user, there are two folders for this app : %appdata%\CPage and %appdata%\WebApps. They are both in the exclusion list, as in the antivirus exclusion list.
In the %appdata%\CPage, there are folders for different environment, with many sub-folders. For example : C:\Users\rolpis\AppData\Roaming\CPage\Monteleger-Production\Profiles\cpagei.default
In this folder, the app writes some text files with the .tmp extension. Then the app renames them with the good extension (.dat or .rdf).
It seems that 5 files are often impacted : compreg.dat, xpti.dat, extensions.cache, prefs.js and mimeTypes.rdf
If I use procmon to see what's happening, I can see that when the bug occurs, the rename instruction fails with the error code 0xC0000369 and the file can't get its real extension, so the app displays a white page instead of the normal screen. Every following connection is affected by the bug, until the server reboots.

There is a support ticket on Microsoft Premium create on july 29th 2021 but still no good answer.

What can I do now ?

Maybe its related to that question :
https://docs.microsoft.com/answers/questions/229309/fslogix-unclean-logoff-causing-locked-files-until.html
But I'm not sure, as there is no logoff problem.

Regards,

windows-server-2019windows-server-fslogix
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

0 Answers