question

PiotrWilk-2705 avatar image
0 Votes"
PiotrWilk-2705 asked PiotrWilk-2705 commented

How to disable UAC for UPS update on Users PCs within domain?

Dear all,

First of all, I was redirected here by @DYARIBARHAM-3462 Thanks for a shout.

I am absolutely helpless right now and I do need help from outside to deal with it. It is the most annoying problem I have faced this year.

Since we have updated all machines to Windows 10 Pro 21H1, we are having a problem with a few using that ridiculous UPS WorldShip software which requires the update every single morning! Before we have used the compatibility toolkit which now is not working with this Windows version.

We cannot give admin privileges to users using it so every morning I have to go through all devices myself entering credentials for them.

Is there any chance to turn off UAC prompts for this painful UPS software to users on the domain?

I have tried most of the solutions found online like; Elevated Shortcut (.bat) and Task Scheduler (shortcut with /run /tn to start the app but that won't run the task).

Completely devastated by now.

Please help!

Thank you in advance!

Regards,
Piotr

windows-10-security
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

shashishailaj avatar image
1 Vote"
shashishailaj answered PiotrWilk-2705 commented

@PiotrWilk-2705 ,

I believe you might have tried multiple ways already but I will provide you with my two cent. I understand these little problems at the start of the day can cause much trouble . You also mention that you have tried the compatibility toolkit . However I am going to ask you to do a fresh install of the same using the latest windows Windows Assessment and Deployment Kit. Downloading the right windows ADK for your windows version is important . As you have mentioned you use win 10 pro 21H1 So please download the following version as listed below.

138109-adkversion.png

While installation , make sure you select Application compatibility tools along with everything that is selected by default. This will install the newest version which will be helpful as far as i think. Another way which is easy to try and should work is to select the executable and the dependent executables to run with administrator privileges. As you mention , UPS WorldShip software is something that is causing trouble. You can find out the executable name and try to change the properties for the exe file . Go to the installation location and find the exact executable for this program. Try to check "run this program as an administrator" and hot apply . Check if this works for you . Ideally this program should run in a UAC virtualized space. If this does not then something in the win 10 security might have changed. There are many new features like device guard , credential guard which employ security techniques which may block these kind of overrides sometimes. I do not know exactly about this in detail as its difficult to know all these settings for anyone and mostly some trial and error could fix this for you .


138216-image.png

If you require to change the setting for all users logging onto the system then select the change settings for all users and see if that works. Hope one of the ways work for you . If this does not work and you find another solution , please do share with the community as it will be helpful for other members with similar issues.

Thank you.


  • Please don't forget to click on 130616-image.png or upvote 130671-image.png button whenever the information provided helps you. Original posters help the community find answers faster by identifying the correct answer. Here is how

  • Want a reminder to come back and check responses? Here is how to subscribe to a notification

  • If you are interested in joining the VM program and help shape the future of Q&A: Here is how you can be part of Q&A Volunteer Moderators




adkversion.png (64.8 KiB)
image.png (68.7 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,

As requested I went for the option with ADK Compatibility Tool for Windows 10 Pro 21H1.

I have initially done the exact same thing but the ADK I tried was not working on my version so not sure what happened.

Installed ADK with Compatibility Toolkit, created .sdb with UPS nightmare.exe file and it works just fine!

Thanks for the help!

Regards,
Piotr

0 Votes 0 ·