question

voldemort12-6643 avatar image
0 Votes"
voldemort12-6643 asked voldemort12-6643 answered

Cannot find any search result from document library

Hi all,

for some unknown reason I cannot find anymore anything when I do a search in document library at Sharepoint Online. There is also one other user who cannot find anything. This is what happens.

  • When library is opened, all the documents are well visible with metadata.

  • If I do a search with metadata (like always previously) the search tells me "We couldn't find any results for *"

What is this? Yesterday I had no problem. Like I said there is one user + me that has this problem. All of the others can make a search with correct result.

Your help is utterly needed.

office-sharepoint-online
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

EmilyDu-MSFT avatar image
0 Votes"
EmilyDu-MSFT answered EmilyDu-MSFT commented

@voldemort12-6643

Whether this issue occurs in a specific library or all libraries? In one site collection or all site collections?

Whether you use modern list search or classic list search?

Whether you could see documents but cannot search in the document library?

Please search with other metadata to test whether search works well.


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 6
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @EmilyDu-MSFT, thank you for your answer.

this user cannot do a search in any document library. They cannot find any results. Only answer is this: 141920-image.png



However for e.g if I do a search in a same library with same metadata, I can find what I want. This is modern search. They can see all of the documents before search, but with search they cannot find anything.


This concerns only one user. They have owner permission of the site. Other metadata doesn't work aswell.

0 Votes 0 ·
image.png (18.0 KiB)

@voldemort12-6643

Please try to remove the user from this site collection, clear browser cache, then re-add the user into this site collection. After that, test whether search works well.

0 Votes 0 ·

@EmilyDu-MSFT thanks again, but unfortunately this didn't help. I removed the user from the site by using Sharepoint Admin center. Then user cleared browser and I re-added them, but the user still receives error of not getting any results.



0 Votes 0 ·

@voldemort12-6643

It's so weird. I suggest you open a service request with Microsoft.

0 Votes 0 ·

@EmilyDu-MSFT probably need to do that. Thanks for help anyway.

0 Votes 0 ·
Show more comments
voldemort12-6643 avatar image
0 Votes"
voldemort12-6643 answered

Hi again @EmilyDu-MSFT,

apparently the removal of user and then adding back again worked after all. It just took longer time. Anyway, all good now again with this user.

Answer accepted and another thanks. Case closed. :)

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.