question

CalvinTeater-1334 avatar image
0 Votes"
CalvinTeater-1334 asked prmanhas-MSFT edited

Unable to connect Azure VM to Mac using RDP

Hi,
I created my infection monkey virtual machine for a testing environment. Allowing inbound port 3389 rule for the network. Downloaded the Microsoft Remote Desktop on my Mac and tried connecting the virtual machine, but it still comes up with Error Code 0x024 "We couldn't connect to the remote PC. Make sure the PC is turned on and connected to the network, and that remote access is enabled." I have already redeployed my VM before and it still has not worked, so I am not sure how to connect my Mac to the virtual machine. I followed the troubleshooting page instructions and nothing seems to help. The group containers folder is not on my Mac either. It would be great if someone could help me with this. Thank you.

azure-virtual-machines
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SenzoNgcobo-8781 avatar image
0 Votes"
SenzoNgcobo-8781 answered SenzoNgcobo-8781 commented

Yes, Im sorry I had missed that in your initial question. Although I am not familiar with this image, I have gathered that you would not be able to log onto it in the traditional way.

Please head over to your web browser and type in https://{vm1PublicIP}:5000 to access Infection Monkey

Please mark this question as answered

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Or alternatively SSH onto the machine should work as well.

0 Votes 0 ·
SenzoNgcobo-8781 avatar image
0 Votes"
SenzoNgcobo-8781 answered

Hi, what version of Microsoft RDP did you install ? Should be v10 and up.

Also type this on a web browser from said MAC http://portquiz.net:3389/ , to test if port 3389 is allowed from your network ?

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

CalvinTeater-1334 avatar image
0 Votes"
CalvinTeater-1334 answered SenzoNgcobo-8781 commented

I currently have v10.7 of Microsoft RDP and when I typed in the URL with the 3389 at the end, I was able to access the website.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Great, do you have the NSG to allow RDP TCP port 3389 applied on the Interface of the VM or Subnet ?
For Inbound connections, the Subnet will first be evaluated and then vNIC. So make sure that nothing is blocking from both NIC and Subnet.

Can you send a screenshot of the NSG that is applied on the NIC and Subnet please ?
Do a tracert from your MAC to the public IP of the NIC, assuming that is how you need to access the VM through the internet ?

0 Votes 0 ·
CalvinTeater-1334 avatar image
0 Votes"
CalvinTeater-1334 answered

144253-screen-shot-2021-10-27-at-100555-am.png


144140-screen-shot-2021-10-27-at-100555-am.png




Here are the pictures. I am currently doing the trace route right now and the rest of it is *** for the hops


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

CalvinTeater-1334 avatar image
0 Votes"
CalvinTeater-1334 answered

144273-screen-shot-2021-10-27-at-100536-am.png




Sorry, I uploaded the same picture twice. Here is the other screenshot.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SenzoNgcobo-8781 avatar image
0 Votes"
SenzoNgcobo-8781 answered

Thanks for the reply, I can see that this NSG is associated to the vNIC.

First thing to look at is if you configured your rule correctly. Did you specify the source port ranges to all (*) ? and not just 3389 ?

Further more I would ask that you please check on the /default subnet if you have any NSGs and if they are allowing RDP port 3389 and to make sure that source port is set to all by using an asterisk *



5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

CalvinTeater-1334 avatar image
0 Votes"
CalvinTeater-1334 answered CalvinTeater-1334 edited

Yes, I configured the rule to allow all port ranges for the source ports. This is what is listed in the /default. I'm not sure if this is what you were looking for or not. Otherwise, I will need some guidance on how to do the rest of this.

144206-screen-shot-2021-10-27-at-105117-am.png



· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I know this may sound a bit silly, but what image did you use to create the vm ? Windows or Linux ?

0 Votes 0 ·

It is actually the Infection Monkey Gen1 image. Could this be the problem? Because I even tried connecting to the virtual machine on my windows virtual box machine and it still won't connect.

0 Votes 0 ·