Protection could not be enabled, as the information about the virtual machine could not be retrieved.

Sherlon Martina 21 Reputation points
2021-11-09T14:30:06.983+00:00

Dear Forum,

I currently at a lost.

I have a total of 11 VM that need to be protected. The process was going smooth but there are 2 VMs that do not enable protection.

The agent install, I can see it in the programs and application.

The logs list as successful. However I get the error below.

I followed the manual install with no luck. I have been searching in forums of a week now.

Error ID
78007
Error Message
The requested operation did not complete.
Provider error
Provider error code: 31332

Provider error possible causes:

  1. The agent on the source server is not responding or could not connect to the configuration server.
  2. The registration of the mobility service with the configuration server could not be completed as the virtual machine has multiple network interface cards attached.
  3. The configuration for replica Backup machine exists. This issue is caused by enabling replication on a replica machine, which has been recently brought up by a Backup software.
  4. For physical machines, if SAN cluster IP address configuration exists, then all those physical machines could end up being assigned the same IP address.

Provider error recommended action:

  1. Check if port 443 of the configuration server is reachable from the source machine.
  2. Try to register the mobility service to the configuration server manually by following the instructions at https://aka.ms/installandconfiguremobilitysvc
  3. Uninstall the Mobility Service Agent on the replica Backup machine and delete it. Wait for 15 minutes to perform fresh vCenter discovery. Refresh the configuration server from portal. Perform a fresh installation of Mobility Service Agent and then retry the enable replication job.
  4. As physical machine discovery is based on IP address, it is recommended to remove the SAN cluster IP address configuration across machines. Once that is done, uninstall the agent and refresh the configuration server from portal. Then execute enable protection again for those machines.
  5. Go to programs list on Control Panel of configuration server and check if ‘Microsoft Azure Site Recovery Mobility Service/Master target Server’ is installed. If it is missing, follow the instructions given at https://aka.ms/error_code_31332 to resolve the issue.

Possible causes
Check the provider error for more details.
Recommendation
Resolve the issue as recommended in the provider error details.
Related links

https://aka.ms/installandconfiguremobilitysvc
https://aka.ms/error_code_31332
Azure Site Recovery
Azure Site Recovery
An Azure native disaster recovery service. Previously known as Microsoft Azure Hyper-V Recovery Manager.
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  1. SadiqhAhmed-MSFT 37,921 Reputation points Microsoft Employee
    2021-11-09T19:49:27.753+00:00

    Hello @Sherlon Martina Sorry for the inconvenience this must have caused!

    You have to restart your Virtual Machine for the Mobility agent to start responding and communicating with your Recovery Services Vault. If the restart still does not fix it then uninstall the mobility agent from the machine, unprotect the machine and then re-protect again.

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