question

RickSomeone-1151 avatar image
0 Votes"
RickSomeone-1151 asked AllenLiu-MSFT commented

Problem with a silent install application.

I have an application that I first copy to the desktop and later install.

Using a run command, I can use: "C:\users\administrator\desktop\setup.exe /silent /wait

Adding that into a CMD line in my TS, I see the box come up as if its installing....there is no Yes, No, Continue...
nothing to click to proceed.

However, the install box sits there with nothing happening until I click within the box.
I am not sure why.

In my TS, I've tried
cmd /c "Path\setup.exe" /install /wait and also

start "" cmd /c "Path\setup.exe" /install /wait (and without wait).

It still makes me click on the box before it installs.
any ideas/suggestions why and what to do? I have others doing this fine.

mem-mdt
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

AllenLiu-MSFT avatar image
0 Votes"
AllenLiu-MSFT answered AllenLiu-MSFT commented

Hi, @RickSomeone-1151
Thank you for posting in Microsoft Q&A forum.

You may try below command to see if it helps:
START /WAIT "Path\setup.exe" /silent


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




· 7
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

As it is a duplicate to the thread: https://docs.microsoft.com/en-us/answers/questions/628147/i-have-a-batch-file-running-an-exe-that-doesn39t-c.html

So the answer I mentioned in another thread is useful, right?
start /wait Path\setup.exe /silent /w

0 Votes 0 ·

I've decided to try to just run this exe in a command line in my TS.
What I have is:

cmd /c "C:\users\administrator\desktop\win8\folder\setup.exe" /silent

This starts the install and it never installs....it just hangs until I go clicking around the screen several times.
Running this in a Run command has no issue at all.
The /silent is the correct switch.
Do I need something else in my command line for this to just run without intervention?

I did away with the batch file...nothing was successful. The basic command line in a TS should work.
It just doesn't take off.

0 Votes 0 ·