question

JohnFriesen-0768 avatar image
1 Vote"
JohnFriesen-0768 asked ·

How to debug Azure monitor alert secure webhook?

Is there a way to debug to see if the service principal is working correctly? I am trying to implement it but I can't figure out if the issue is my app registration or what it might be complaining about. Are there any logs for this?

azure-monitorazure-ad-app-registration
· 4
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@JohnFriesen-0768 Thanks for your question. I am checking the issue and I will update you soon.

0 Votes 0 ·

@JohnLinderman-5146, What kind of errors are you seeing? Can you share some of the errors, so that it gives us a better understanding to help you further?

0 Votes 0 ·

@soumi-MSFT i am not seeing any errors and that is the issue.
here is a rundown of what I am trying to do.
Azure monitoring alert action group -> use secure webhook -> send the request to azure function -> save blob (just to verify execution)

I have followed this documentation as best as i could https://docs.microsoft.com/en-us/azure/azure-monitor/platform/action-groups#secure-webhook
But it is not clear as to how AD app registration needs to be setup that I am linking to the Alert secure webhook.

The function Authentication/Authorization has been setup correctly from my perspective (i followed a couple of tutorials as to how to secure them with function to function AD security)

The function is not being hit from what I can see in application insights. I suspect that i am missing something with the AD app registration i am using for the webhook.

0 Votes 0 ·

@JohnFriesen-0768 We recommend engaging our technical support team to investigate further. Please file a support case using these steps. If you do not have a support plan, send mail to AzCommunity@microsoft.com, include your subscription ID and a link to this thread (for context).Once we have a resolution, we will post the update to this thread so others in the community can benefit.


0 Votes 0 ·
JohnFriesen-0768 avatar image
0 Votes"
JohnFriesen-0768 answered ·

Just to answer my original question.

There are no logs available to azure users. They do exist but can only be accessed by Support Engineers.
After creating a support request I was able to get some log information relayed that helped me understand what was going on.
Not ideal by any means but that's how it is right now.

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ShachafGoldstein-0199 avatar image
0 Votes"
ShachafGoldstein-0199 answered ·
·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.