question

sdulany-9868 avatar image
0 Votes"
sdulany-9868 asked ·

Installing ADDS and DNS offline

Hello, Seemingly recently when installing ADDS and DNS in an offline fashion, DNS does not seem to get set up correctly. The _msdcs.my.domain forward lookup zone is not being populated at all with the needed SRV records and thus no other computers or domain controllers can do the required DNS lookup check on it to be able to join. If I do the exact same install, either via my automated scripts or by hand, online everything seems to be fine. So my question is if under a recent windows update some things got moved to online installs and thus behavior for these installs has changed? I receive no errors on the installs themselves however once I do DCDIAG on the offline installed version DNS is all kinds of messed up from not having all the SRV records. Is there a way for me to bring the packages which got moved online back offline like they used to be?

azure-active-directory
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

shashishailaj avatar image
0 Votes"
shashishailaj answered ·

Hello @sdulany-9868
I believe you are using Install from Media Option to install Active Directory Domain Services. I am not sure of the windows version you are using but I do not think this would be due to any packages that might/might not have moved. Up until the current windows server 2019 the IFM is available as an option for deployment and no components required for IFM have been changed as per my information. netlogon.dns is the file which has the service records that need to be published to the DNS . It is located in %systemroot%\System32\Config location. I would suggest a logical troubleshooting as following .

  • Verify the Netlogon.dns file on the server where you created the media. Make sure the netlogon.dns file had all the required SRV entries as mentioned in linked article.

  • During IFM we select a domain controller to copy additional replication information from , I would suggest to check the DC from where we are replicating this data. (This one is highly unlikely to become cause of the issue.)

  • If the above is correct then check the netlogon.dns after IFM process is complete on the local machine if the records are present or not . If you have records then the machine have some service issues and some ETL tracing would be required to find out why dynamic registration of SRV records to DNS failed.

If this is one off behavior , I would suggest to try installing again using same media after checking the above points . If this is a consistent behavior with same Media , I woudl suggest creating a new IFM media and trying with that. If you still face the error consistently, I would suggest to open a troubleshooting case with us. It is very very unlikely though , however it may be some regression . But chances of regression are extremely low.

Also with Improvements in technology and networking bandwidth , IFM is seldom used now a days. If you have any specific use case and it is not working , I would suggest to open a support case with Microsoft to further troubleshoot this.

Hope this helps. In case the information provided in this post help you solve the problem , please do share your findings with us and mark it as answer so that it can help other community members who have similar queries. In case you have further queries , please feel free to reply with a comment to my post.

Thank you.




·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.