question

ArnavBhate-1918 avatar image
0 Votes"
ArnavBhate-1918 asked ArnavBhate-1918 answered

Not able to run VMs on Hyper-V

See the image for error.

161240-image.png

Virtualization is enabled in UEFI. I've run Hyper-V VMs on this install of Windows 10 before. Also, coreinfo64 reports that the processor does not support VT-x but it actually does. It is an Intel Core i5-6200U. WSL gives error 0x80370102 while installing a distro.



windows-10-hyperv
image.png (15.0 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

vb2ae avatar image
0 Votes"
vb2ae answered ArnavBhate-1918 edited

Check that virtualization is enabled in the computer bios for the processor. I would also double check your motherboard supports virtualization

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

It is enabled, I mentioned in the question. As I said I have run Hyper-V VMs before on this install of Windows.

0 Votes 0 ·
ArnavBhate-1918 avatar image
0 Votes"
ArnavBhate-1918 answered

I fixed this issue myself following these steps:

  1. Open Windows Security.

  2. Go to App & Browser Control.

  3. Go to Exploit protection settings.

  4. Go to Program settings.

  5. Set C:\Windows\System32\vmcompute.exe and C:\Windows\System32\vmwp.exe to 0 system overrides.

  6. Restart these processes.

Now I am able to run VMs in Hyper-V.




5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.