question

joediesel-5172 avatar image
0 Votes"
joediesel-5172 asked joediesel-5172 commented

Cannot create virtual internal (and external) switch in Hyper-V (0x80041002) on Win 10 Pro

I had a situation where a VM in Hyper-V on Win 10 Pro (build 19043.1415) wouldn´t stop and the first thing I did was stopping various services related to Hyper-V. After that I rebooted the host, and suddenly all my VM`s were no longer listed in Hyper-V. I thought this was weird, cause usually you´d expect these services to come back after a reboot. Anyway, I tried restarting services related to Hyper-V, but they all seemed to have a dependency, unnamed, prevending them from running. After a bit of trying to resolve it, I decided to simply uncheck Hyper-V as installed, reboot and then check it as installed + reboot again. Now I could see my machines again, but ran into a new problem: The virtual internal switch that I use for connecting through my VPN was gone. So I tried creating it, both with Hyper-V and from PowerShell, but with the same result:

New-VMSwitch -Name Intern -SwitchType Internal
New-VMSwitch : Virtuelle Ethernet-switchforbindelser kunne ikke tilføjes.
Intern miniport kunne ikke oprettes. Navn = '1F870B16-E6E9-4D9E-83EC-7A114ACB9A49', brugervenligt navn = '', MAC = 'DYN
AMIC': Not found (0x80041002).
At line:1 char:1
+ New-VMSwitch -Name Intern -SwitchType Internal
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [New-VMSwitch], VirtualizationException
+ FullyQualifiedErrorId : Unspecified,Microsoft.HyperV.PowerShell.Commands.NewVMSwitch

Please bear with the message being in Danish, but it´s basically telling that Virtual internet switch connections could not be added and the internal miniport could not be created. The same thing happened when trying to add an external switch. It takes up to 2 mins before I get the message btw. I found others with what seemed to be a similar problem, but here the solution was to remove Hyper-V (in already mentioned way) and do a netcfg -d, reboot, reinstall hyper-v and reboot, but this did not make any difference for me. I also found a hotfix from MS dated 2021, that did not improve my situation either.
Finally, I´ve done a sfc /scannow as well as repair installing Win-10.
FYI, I can start the machines, but with the only available virtual switch type = private.

Some good ideas apart from reinstalling Windows completely?

windows-10-hyperv
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Found the solution: Unistalled Comodo Internet Security, rebooted and I could proceed with creating the switch. I did not have to do this when I created a switch a few months ago, but there´s probably a conflict between Comodo and a recent Win 10 update causing this.

0 Votes 0 ·

0 Answers