question

ZacWatkins-1957 avatar image
1 Vote"
ZacWatkins-1957 asked AsmaaEltayary-0898 published

Fixing Error 0: No process is on the other end of the pipe.

Recently trying to work on some SSRS stuff with a local instance of my company Database, and I messed with number of allowed connections. Now attempting to connect to my local instance yields:

Microsoft SQL Server Management Studio



Cannot show requested dialog.


ADDITIONAL INFORMATION:

Failed to connect to server DESKTOP-68S3Q92. (Microsoft.SqlServer.ConnectionInfo)



A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&EvtSrc=MSSQLServer&EvtID=233&LinkId=20476



No process is on the other end of the pipe



Interestingly, if I restart my server from SQL Server Configuration Manager it will successfully connect, but then immediately give the same message, and prevent me from touching properties or anything else.

If anyone has some insight to the problem I would be most appreciative, I'm still pretty new at this SQL game.

sql-server-general
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MiaMiao-MSFT avatar image
1 Vote"
MiaMiao-MSFT answered MiaMiao-MSFT commented

Hi @ZacWatkins-1957

A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

Enable TCP\IP protocol and then test it again.

Steps as next:
1 .Turn off your firewall and antivirus software;
2.Enable the TCP\IP protocol both in server and client side and use 1433 port.
3.Restart the SQL Service and try again.

More detail steps :setting-up-management-studio-for-remote-sql-server

More helpful information: how-to-connect-to-a-remote-sql-server


BR,
Mia
If the reply helped, please “Accept Answer” and upvote it.--Mia


· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Tried turning the firewall off just now, already had TCP\IP enabled, same with shared memory and named pipes. Still no luck. Thank you for your response though! I'll keep plucking away at the problem.

0 Votes 0 ·

Hi @ZcWatkings-1957,

Disable shared memory and named pipes, just only keep the TCP\IP enabled.
And do you enable the TCP\IP both in server side and client side?

19317-20200819clientprotocol.jpg
19433-20200819serverprotocol.jpg


BR,
Mia
If the reply is helped, please do "Accept Answer".--Mia


0 Votes 0 ·
Shashank-Singh avatar image
1 Vote"
Shashank-Singh answered AsmaaEltayary-0898 published

Can you please check below two Stackoverflow links, they are highly voted answer and points to step that you enable mixed mode authentication and restart SQL Server service. I don't know logic behind this but please test and let me know if that works for you

a-connection-was-successfully-established-with-the-server-but-then-an-error-occ


No process is on the other end of the pipe (SQL Server 2012)


· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thanks for the links.. The first one worked for me.

0 Votes 0 ·

Thanks for the links.. The Second one worked for me

0 Votes 0 ·

yes it is worked for me without need to change TCP/IP protocol

0 Votes 0 ·
SandroDiMuccio-7852 avatar image
0 Votes"
SandroDiMuccio-7852 answered TylerWilkin-6296 published

hello everyone i had the same problem and i solved it by disabling password expiration,
I hope this will help

Disable password expiration on SQL user login

  1. Open SQL management studio

  2. Login with an appropriate admin-level account (using either Windows or SQL authentication)

  3. Expand Security – Logins

  4. Right click the desired login and choose properties

  5. Untick enforce password expiration

  6. Choose OK

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thank you @SandroDiMuccio-7852 your solution worked for me.

0 Votes 0 ·

Thanks, fixed it for me too.

0 Votes 0 ·
RalR-4989 avatar image
0 Votes"
RalR-4989 answered

Hi,

In my case, Login was set it up only as Windows user, therefore I could not login as SQL Server user. I could not find out how or who did the change. Anyway, I found a way to fix it by changing the Loginmode thruogh the registry.

Open the registry and go to HKLM \ Software \ Microsoft \ Microsoft SQL Server \ <instance> \ MSSQLServer \ LoginMode
then change the value to “2” for the mixed mode.

Restart SQLServer services. Now you should able to login as Server user

Regards

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.