question

som avatar image
0 Votes"
som asked ·

Azure Mobile app

I have UWP app backend is azure mobile app service. I have configured azure b2c as authnetication. from last six month it is working fine.
on my client side i am using DefaultManager.CurrentClient.CurrentUser.UserId which give me userid {sid:value} format.
on server side this code was also giving {sid:value} and provider was aad

 var identity = User as ClaimsPrincipal;
 var userClaim = identity?.Claims.FirstOrDefault(b => b.Type == ClaimTypes.NameIdentifier);

from 20 December it is giving directly from b2c.
when i send the same request to local code it works as expected. but if i debug using attaching to azure mobile app. i am getting the same different value.

Now from 21 Jan on server it is again giving userid as {sid:value} format.
what is the correct format i can not keep changing my code.

https://github.com/Azure/azure-mobile-apps-net-server/issues/33



windows-uwpazure-ad-b2c
· 7
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @som,

We're currently investigating this issue as you weren't the only one to experience. I'll update the post once relevant information becomes available.

Thanks and apologies for the inconvenience,
Ryan

0 Votes 0 ·

Hi @ryanchill any updated since i am stuck and my users are not able to get the data.

0 Votes 0 ·

Is there any update? this is killing us...

0 Votes 0 ·

What different value are you getting? Sorry if I misunderstand, but can you clarify what the expected outcome is and what you are receiving?

0 Votes 0 ·

it is not about the value it is more about format.
earlier it was user id was {sid:guid} which generated i think based on some algo. this is called stable id.
then it again started giving the userid as only guid this time is from Azure AD B2C identifier.
on 20 Jan it stated again giving the stable id in {sid:guid} format.
i can not keep changing my code. my users stopped getting data.



0 Votes 0 ·

we are also having the same issue - this is a major change management issue and we need this to get resolved ASAP also - our users also cannot retrieve data. What is the root cause of this issue. this is a MAJOR problem.

mid - december we also found our code was not working which was fine for the last year. my developer found that MS had changed the format as above and then we fixed our code - note there was NO change log from Microsoft communicated about this major impact change.

now since last week something has changed again.

Please elevate this issue to your Critical 1 issue list!
Prem

0 Votes 0 ·

@som @PremSundaram-1153 this issue has been resolved. Please allow me to convey my most sincere apologies for not responding sooner.

0 Votes 0 ·

1 Answer

MarileeTurscak avatar image
0 Votes"
MarileeTurscak answered ·

Hi,

Thank you for raising this to our attention! I have created a bug to address this. As of yet I have not seen an update from the PG. If you send me an email at AzCommunity@microsoft.com I can keep you in the loop on fixes to this.

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.