question

SKR-5908 avatar image
0 Votes"
SKR-5908 asked ·

Cannot access Oracle12c Database from outside the AzureVM, can connect inside VM

Dear Friends,

I Installed Oracle 12c in Azure VM (Windows server 2012r2). I did all configuration steps and I can access my Oracle instance from inside the VM, including the Oracle Enterprise Manager.

But i can not connect/access outside the VM.

URL: https://VMmachineName.xxxxxxxxxxxxxxxx.cx.internal.cloudapp.net:5500/em
Oracle Port 1521

(1).Set firewall New inbound rule in my VM, for port 1521.
(2).I have created inbound rule in my VM portal for 1521 and 5500

Ports are open,

Still can not access oracle database outside AzureVM
Please help me solve this issue.

Already there is one thread for same issue, is not working
https://social.msdn.microsoft.com/Forums/en-US/bb352d38-6957-4288-9f78-09f6c96c2a73/cannot-access-oracle-enterprise-manager-from-outside-the-vm?forum=WAVirtualMachinesforWindows

Please
Thanks

azure-virtual-machines
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

vipullag-MSFT avatar image
1 Vote"
vipullag-MSFT answered ·

@SKR-5908

Firstly, apologies for the delay in responding on this and any inconvenience this issue may have caused.

Based on the port information shared, from this Azure documentation, I see that 1521 and 5502 ports need to be opened.

To quickly check if the required ports are open as expected, you can quickly check using this tool. Please check if the public IP is opened the required ports. If you see the result as closed, the the NSG is not setup properly or there is any firewall blocking this access on your end.

Please follow this document and let us know if you are still facing issue in accessing.



Hope this helps.

Please 'Accept as answer' if it helped, so that it can help others in the community looking for help on similar topics.

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SKR-5908 avatar image
0 Votes"
SKR-5908 answered ·

Dear Vipula,

I already checked , port are open,
as i said in first thread,
(1) set firewall inbound rule in VM machine for 1521
(2).In my VM portal (Public ip) i inserted inbound rule for 1521 and 5500.

I really i did not understand what went wrong,
I can connect database inside the VM perfectly both cantainer and pluggable database working , no issue at all

Please
Thanks

· 4 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@SKR-5908

If you know the IP address of the machines outside azure where you are trying to connect, you can use Network Watcher available in Azure that will help you identify the security rules that is preventing the connection.

If you are still running into issue, then this issue needs live troubleshooting to assist you better. Will recommend to open a support case if you have a support plan. If you don't have a support plan, please let me know so that we can help you with the support case.


0 Votes 0 ·

Yes Vipula,
I checked with net watcher, "Port Allowed",
Actually i am in free trail of Azure, I think i do not have support plan.
How to help me to get out of this issue.Please
Thanks



0 Votes 0 ·

Yes Vipula,

Same issue remains there
ORA-12545: Connect failed because target host or object does not exist

Thanks

0 Votes 0 ·

@SKR-5908

Could you send an email to AzCommunity[at]Microsoft[dot]com referencing this thread as well as your subscription ID. Please mention "ATTN: Vikas" in the subject line. We will try and help you get a one-time free technical support. And then you can open a support request.

Thank you for your cooperation on this matter and look forward to your email.


0 Votes 0 ·
u201710729LunaPinoMarcosAugusto-1691 avatar image
0 Votes"
u201710729LunaPinoMarcosAugusto-1691 answered ·

I had the same problem with the database and after several hours I solved it by editing the file listener.ora. Change "(ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))" to "(ADDRESS = (PROTOCOL = TCP)(HOST = 0.0.0.0)(PORT = 1521))".

78500-oracle-listener.png
Don't forget to restart the server.
I hope the input helps.


oracle-listener.png (13.5 KiB)
·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.