question

HenryPrins-7382 avatar image
0 Votes"
HenryPrins-7382 asked RICHARDMEADOWS-3482 answered

Remote Desktop Always on top after minimize/maximize

Has anyone been able to get a fix for the Windows 10 RDP client getting stuck in what appears to be "Always on top" state?

I've seen reports of this bug on line going back to 2017.

When you first connect to a new RDP session you can open new applications on your local desktop and they will show up above the RDP client. However once you minimize and maximize the RDP session, for what ever reason all new applications that get created in the same screen will "pop up" hidden behind the RDP session. This is an overly annoying issue when you work with many apps and remote desktops throughout the day.

Since this has been going on for YEARS now, I was hoping I would find something online, but either I haven't been able to find the correct search criteria or this BUG has simply been ignored by Microsoft.

windows-10-generalremote-desktop-client
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Same issue is continuing almost a year later

0 Votes 0 ·
JennyYan-MSFT avatar image
0 Votes"
JennyYan-MSFT answered PeterPilka-9002 commented

Hi,
Thanks for posting in our Q&A forum. But to understand your problem better, could you please clarify the steps with more details for us to test further?

I did a quick test but failed to reproduce your issue.
1.Remote from a dual-monitors Win10 to another Win10 via mstsc, uncheck use all monitors in order to open new application from local desktop when there is a full screen remote session.
2.When remote session connected, open new application from second monitor and it popped up in the front.
3.Minimize full-screen remote session then maximize it, again open new application from second monitor, it was still brought in the front.

The test OS version is: 1903
20409-image.png

Looking for your update.

Best Regards,
Jenny



image.png (52.1 KiB)
· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

This is a general failure in Windows. A simple google search gets you a vast number of hits and Microsoft has yet to be able to reproduce it?
I currently run 2004 but have had this behaviour in the last two previous builds as well I believe.

Symptoms: Establish a RDP to another machine (usually one does not connect to another Windows 10 machine; far more common to a server like Windows Server 2016 or 2019).

Have your outlook client running.
Get a notification on new mail and click outlook.
Notice that it won't show and you click it again; where is it? Oh yeah, its probably stuck behind your RDP, so you minimize that window. And lo and behold, there it is.
This is the same for all windows; they are all hidden behind RDP.

Surely this can't be difficult to reproduce on a new machine?

Best Regards from Sweden.

2 Votes 2 ·

Hi,
Is there any update?

Please feel free to let us know if more assistance needed.

Thanks,
Jenny

0 Votes 0 ·

Pretty much what Henrik says. Dual-monitor, try to open an app that is on the same monitor as the RDP session (Windows 10 clients, not servers for me) and it maximizes under the RDP session. Need to minimize the RDP session to get to it.

0 Votes 0 ·

Pretty much what Henrik says. Dual-monitor, try to open an app that is on the same monitor as the RDP session (Windows 10 clients, not servers for me) and it maximizes under the RDP session. Need to minimize the RDP session to get to it.

See also this thread https://social.technet.microsoft.com/Forums/windows/en-US/9fcf14e3-b831-443e-8d3b-7d7b6fbf6faf/remote-desktop-app-quotalways-on-topquot-after-fall-creators-update?forum=win10itprogeneral

0 Votes 0 ·

Hi,
I have the same issue with RDP always on top. I reproduced steps by JennyYan-MSFT to reproduce the issue. Crucial point of the sequence is "uncheck use all monitors". The punchline of the issue is, that in case of unchecked checkbox it is necessary to check and uncheck it. So description for reproducing the issue is:
1.Remote from a dual-monitors Win10 to another Win10 via mstsc, checkbox use all monitors is already unchecked in order to open new application from local desktop when there is a full screen remote session.
And workaround is to check and uncheck the "use all monitors" in order to open new application from local desktop when there is a full screen remote session.
Best regards
Peter

0 Votes 0 ·
lukval avatar image
6 Votes"
lukval answered WeekendWang commented

In my situation (Windows 10 Ent LTSC 1809) works the solution on https://social.technet.microsoft.com/Forums/windows/en-US/9fcf14e3-b831-443e-8d3b-7d7b6fbf6faf/remote-desktop-app-quotalways-on-topquot-after-fall-creators-update?forum=win10itprogeneral ... open default rdp file with a text editor and changed the setting "videoplaybackmode:i:1" to "videoplaybackmode:i:0".

· 7
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

  • This had no effect for me.

  • Problem persists.
    -Daily hassle.

Effectively, I cannot use one monitor (keep all my windows on other monitor(s)) unless I want to use the mouse to minimize.

Ctrl-Alt-Home then Alt-Tab doesn't work either.

Unrelated to Outlook. Can reproduce with Notepad++ and RDP and no other windows open.






1 Vote 1 ·

I also have this issue. One keyboard based work-around I use is the aero-snap functionality (Win-Key + arrow keys) to force it over to the other screen and maximise it. It's not ideal as my other screen is a 13" laptop screen - there's a reason I'm primarily using an attached monitor - but it does get it onto the other screen without minimising the RDP session.

Hopefully a fix will be forthcoming soon though I'm certainly not holding my breath

0 Votes 0 ·

Great, that's working for me 👍

Found the default.rdp under c:\users\documents\default.rdp

hope it stays tha way..

1 Vote 1 ·

Hey, this one worked for me, thanks! Still its inconvinient if one uses multiple target PCs.

0 Votes 0 ·

Hi Oliver, you can click Show Options then Save As, save your every target to a single *.rdp file.
Change videoplaybackmode respectively then you can double click the foo.rdp and bar.rdp to connect multiple target PCs.

0 Votes 0 ·

Yes! Thank you!!

0 Votes 0 ·

This worked for me BUT the current version of my default.rdp file did not have the videoplaybackmode:i:0 string. I was able to cut and paste it from an older version of the file and now new windows show up in front of Remote Desktop.

If you don't see "videoplaybackmode:i:1" when you open the default.rdp file in Notepad, just add it,change the last digit to 0, save the file, and restart Remote Desktop. Solved.

0 Votes 0 ·
RICHARDMEADOWS-3482 avatar image
0 Votes"
RICHARDMEADOWS-3482 answered

Setting videoplaybackmode:i:0 resulted in my session not running full screen. Was only 1080p I have 1440 ultra wide.

Noticing that if I select display 1 size down from 'Full Screen', I get desired result. <sarcasm>That wasn't confusing at all </sarcasm>

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.