question

anuraj avatar image
0 Votes"
anuraj asked ·

Error : Click Authorize to configure an Azure service connection. A new Azure service principal will be created and added to the Contributor role.

I am getting this error while configuring Azure Web App deployment. The build pipeline already contains a web app deployment, I am trying to add one more.

EPlSnOeUcAAR_I2

azure-webapps
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

anuraj avatar image
0 Votes"
anuraj answered ·

I resolved it. Instead of adding a new web app deployment step - which was causing issue. I cloned the properly working step and changed the target web app. And it worked without any issue.

· Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SnehaAgrawal-MSFT avatar image
0 Votes"
SnehaAgrawal-MSFT answered ·

Thanks for asking question! It looks like you don’t have the required permissions on the AAD, and thus you are not able to configure. Please refer to the below link might be helpful:

https://docs.microsoft.com/en-us/azure/devops/pipelines/release/azure-rm-endpoint?view=azure-devops#the-user-is-not-authorized-to-add-applications-in-the-directory

https://docs.microsoft.com/en-us/azure/app-service/overview-authentication-authorization

Let me know if issue persists.

· 1 · Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thank you for the response.

I am using a subscription level user in the Azure portal to connect the web app from Azure DevOps. And it is working properly for existing web app deployment. It is happening only when I am trying to connect with new web app.

0 Votes 0 · ·