question

SAnandhakrishnanCognizant-6991 avatar image
0 Votes"
SAnandhakrishnanCognizant-6991 asked PardeepPardeep-8151 edited

Unable to login to Visual studios 2013 upgrade 5

190868-vs.pngHi all,

we have an outage for 3 users in a project where they are not able to login to visual studios upgrade 5 2013 it shows an error like

sorry we ran into a problem

online service not aviable


145999-screenshot-13.png

i am attaching the error screenshot here also issue has been reported in Microsoft website and we have followed all the FLS mentioned by other user in the forum which still remains un answered

Not able to sign in to Visual Studio 2013 with update 5. - Microsoft Q&A

requesting inputs for resolving this


vs-general
vs.png (19.5 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SAnandhakrishnanCognizant-6991 avatar image
0 Votes"
SAnandhakrishnanCognizant-6991 answered Pardeep-5739 edited

HI all,

I myself found the fix

we have to enable TLS 1.0 from registry

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\


TLS 1.0 ->Client --> Enabled Dword value 1

issue got resolved

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @SAnandhakrishnanCognizant-6991 ,

I’m glad to hear that this issue was resolved. I appreciate that you shared the solution here, it is helpful.

Have a great day.

Regards,
Tianyu

0 Votes 0 ·

I have same issue but there is no TLS 1.0 ->client option in registry. I am using Windows 10



194086-image.png


0 Votes 0 ·
image.png (109.7 KiB)
AndrewDoering-2967 avatar image
2 Votes"
AndrewDoering-2967 answered PardeepPardeep-8151 converted comment to answer

I ran into this problem as well, but the solution was not enabling TLS 1.0 in the registry. I think it is due to Microsoft discontinuing support for TLS 1.0. Visual Studio 2013 natively calls that protocol to sign-in. You have to force the .Net Framework VS 2013 was built upon to use a more modern protocol, i.e. TLS 1.2

For me, VS 2013 Update 5 appears to be built against v4.0.30319. I forced the 32 bit framework to use strong crypto.

PowerShell script that will add the key:

 New-ItemProperty -path 'HKLM:\SOFTWARE\Wow6432Node\Microsoft\.NetFramework\v4.0.30319' -name 'SchUseStrongCrypto' -value '1' -PropertyType 'DWord' -Force | Out-Null

You can find more information here: https://docs.microsoft.com/en-us/mem/configmgr/core/plan-design/security/enable-tls-1-2-client

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

That solved the problem in our case (two machines). Thanks.

0 Votes 0 ·
PardeepPardeep-8151 avatar image
0 Votes"
PardeepPardeep-8151 answered PardeepPardeep-8151 edited

Thanks

 New-ItemProperty -path 'HKLM:\SOFTWARE\Wow6432Node\Microsoft\.NetFramework\v4.0.30319' -name 'SchUseStrongCrypto' -value '1' -PropertyType 'DWord' -Force | Out-Null

That solved my Problem. Run PowerShell with admin rights and run the above given script.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.