question

teja98666-4126 avatar image
0 Votes"
teja98666-4126 asked ryanchill commented

Id Field mapping not working between azure blob and index

Hi,

I have file stored in Azure blob storage and each blob has a custom meta data property with name as Id.

194698-image.png

Now i created an index in Azure cognitive search and added a field with name as "Id" i.e. matching the meta-data property of the blob hoping that it automatically maps the property to the field in the index.

194677-image.png

When i ran the indexer it doesnt populate the value of the Id property of the blob but instead creates a different unique id.

194734-image.png

i tried using Filed mapping property on the indexer but it throws an error saying that Id property is not available in the Source but as show in the above screenshot the property is still available on the Source.

194718-image.png

How do i map the Id meta-data property on the blob to the Id field in the index. Can any of you help me with this issue?

azure-cognitive-search
image.png (7.7 KiB)
image.png (3.9 KiB)
image.png (12.2 KiB)
image.png (4.3 KiB)
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Apologies for the delayed response @teja98666-4126. I'm going to see if I can repro this scenario following this index how-to for blobs. How did you go about creating your actual SearchIndex?



0 Votes 0 ·

Hi @ryanchill yes i followed the steps in that link. Created Index, DataSource, Indexer using the Azure Portal. This works fine.
Now, i wrote a sample console application based on example here but i used Azure Blob storage as datasource. In the app i mapped Id meta-data property on the blob to the Id property in the index, this is where i get an error that Id property is not available.


1 Vote 1 ·

Thanks for confirming @teja98666-4126. I'll investigate this issue and provide an answer for you.

0 Votes 0 ·

0 Answers