question

Supheria avatar image
0 Votes"
Supheria asked Supheria commented

Don't have enough priority to update Help Viewer 2.3

I want to install msdn from downloaded .ios file, so I have switched the installation resource to that .ios file.

When I added some books and clicked update, the status column shows that some errors happened. I clicked s195063-11fd35057ee2c3ea.pngtatus column and it popped, “You don't have enough priority to complete this task”.

How could I solve this problem?


vs-generalvs-setup
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @Supheria ,

The openspec-* tags are dedicated to supporting issues related to open specifications. You can find open specifications here https://docs.microsoft.com/en-us/openspecs/

Since your question does not pertain to one of these specifications, I've removed the openspecs-questions tag and added the vs-general and vs-setup tags. Hopefully this will get your post the proper attention.

If I've misunderstood your question and you believe this is related to the Open Specifications documents, please clarify, providing the document name and section with which you have the question or issue.

Best Regards,

Michael Bowen
Escalation Engineer - Microsoft Open Specifications

1 Vote 1 ·
Supheria avatar image Supheria MikeBowen-1599 ·

Ok, I'm sorry for using a wrong tag. Thanks a lot.

0 Votes 0 ·

1 Answer

AnnaXiu-MSFT avatar image
0 Votes"
AnnaXiu-MSFT answered Supheria commented

Hi @Supheria,

Which version of Visual Studio are you using?

Please try to run the VS as administrator and update the Help Viewer again.

If it doesn’t work, you can uninstall the Help Viewer from Control Panel and try again.

Sincerely,
Anna


If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi there,

My VS version is 2022 community and Help Viewer is 2.3.

I just tried create a shortcut of HlpViewer.exe by adding with /catalogName VisualStudio15, and it runs successfully in administrator mode.

It seems I can update some books to install finally, but there is yet some can't be updated, such as .NET API Reference - en_us. By the way, the ios file I'm using to install was packed in 2019. Maybe is it to old to install?

Whatever, I just installed books I needed so I won' t uninstall Help Viewer for now.

0 Votes 0 ·

Hi there,

It's me again.

I have tested all books to install. At last I find two books can't be installed, .NET API Reference - en_us and API Reference for Windows Store apps - en_us. I guess these two books are unavailable for VS Community users, right? I installed all books together including unvailable ones at first time, which causes installation failure.

I believe my problem has been already solved.

Best regards.

0 Votes 0 ·