question

IT-2614 avatar image
0 Votes"
IT-2614 asked ·

Cannot connect to my Virtual Machine using the public IP address

I have created a new Windows Virtual Machine using standard settings. I successfully RDP'd into the machine using the public IP address.

I installed Apache on the server and this worked using "localhost" in the browser. The browser will not resolve the public IP address.

I want to be able to browse to the Apache HTTP server using port 80 (default).

When I use "Connection troubleshoot" in Azure the result is successful.

Please help.

azure-virtual-machinesazure-virtual-machines-networking
· 1
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@IT-2614 Glad to hear that your issue is resolved!!!

Do let me know if you have any more queries.

Thanks

0 Votes 0 ·

1 Answer

IT-2614 avatar image
1 Vote"
IT-2614 answered ·

I have managed to resolve it myself.

The virtual machine has Windows Firewall running.

I attempted to turn the service off but it would kill by RDP session and not do anything, so I disabled the service and rebooted the server.

Now I can browse to the virtual machine. Yes!

· 1 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@IT-2614 Thanks for sharing the update. I would recommend marking your answer as 'Accepted'. This would help other people who are facing the same issue, quickly find it.

0 Votes 0 ·