question

Heimdallr avatar image
0 Votes"
Heimdallr asked SimonRenMSFT-3639 commented

OSD Build issues - Language Pack issues

Hi All,

I am building my first TS in a test environment, and I am getting stuck. Currently, I am getting stuck at language pack that I want to have as a step in TS, as I want to try a way with no wim touching, just keep all the settings in TS.
I am using a Windows 21h2 wim file, and my TS is integrated with MDT so I've also tried the built in options to choose install LP offline and online. Both also failed.

Running out of ideas here to be honest, I hoped someone will tell me what I am doing wrong. Machine is a VM by the way. My TS looks like this:
196875-image.png


TS completes successfully, device is in domain and all seems to be good but for some reason, only two apps that do not install, is Edge created via MS Edge management in Config. Manager and that LP. Office installs good(also created by Config. Mgr.)

To have some more tests and visibility, I've tried injecting LP in various places, just in case if task placement would be bad. I might be wrong here but if file is a .WIM, I should apply LP using DISM before OS installs, right?

I've used this one:
196972-image.png


It contains package that has only a lp.cab file in it, downloaded from Microsoft, so it's not a cab from some shady place.

I've put this task before Apply OS, right after Apply OS, After Apply network settings and I've deployed it as an Application, during install App Phase according to this guide https://docs.microsoft.com/en-us/troubleshoot/mem/configmgr/deploy-language-pack

I am honestly running out of ideas here and I bet this is something small that I just can't see.

Logs attached

196966-dism.log
196978-smsts.log


Edit: After more tries, I've found this guide: https://www.manishbangia.com/how-to-install-language-pack-through-task-sequence-windows-10/ which advises to:



Modify your existing task sequence for 20H2, right after the step “Apply Operating System”, click on Add > General > Run Command to add an extra step with following settings:

Name: Install Language pack de-de
Command line: dism.exe /image:%OSDTargetSystemDrive%\ /ScratchDir:%OSDTargetSystemDrive%\Windows\Temp /Add-Package /PackagePath:”.\Microsoft-Windows-Client-Language-Pack_x64_de-de.cab” /quiet


Now, In logs from DISM I got this(can't copy):
196988-image.png
197073-image.png

So I was wondering...This looks to me like it would be searching for that LP cab, where it does not exist for some reason...any hints here?
Also the broken symbols in log screen looks like windows could identify the letter, is it possible that it does not read the correct path because system that installs above, has set input locale to Swedish(not system locale)?










mem-cm-osd
image.png (29.6 KiB)
image.png (11.7 KiB)
dism.log (656.4 KiB)
smsts.log (969.6 KiB)
image.png (219.8 KiB)
image.png (273.0 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

SimonRenMSFT-3639 avatar image
0 Votes"
SimonRenMSFT-3639 answered SimonRenMSFT-3639 commented

Hi,

Thanks for posting in Microsoft MECM Q&A forum.

1,Please help check if the the language pack has been distributed to the DPs successfully.

2,We can try to change the PackagePath to its default name (without double quotes) to have a try, for example:
DISM.exe /image:%OSDTargetSystemDrive%\ /ScratchDir:%OSDTargetSystemDrive%\windows\TEMP /Add-Package /PackagePath:Microsoft-Windows-Server-Language-Pack_x64_en-gb.cab
Similar thread for your reference: SCCM Language Pack Deployment

3,What's the error when we deploy the Windows language pack as an application?

Hope it helps. Thanks for your time.

Best regards,
Simon


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Ok,

You rock. nearly 5 days and now it is fixed! Thank you a lot!


0 Votes 0 ·

Hi,

Thank you very much for your feedback. We're glad that the question is solved now. If you have any questions in future, we warmly welcome you to post in Microsoft Q&A forum again.

Have a nice day!

Best Regards,
Simon

0 Votes 0 ·