question

Ben-2054 avatar image
0 Votes"
Ben-2054 asked SamWu-MSFT answered

The issue about enable 32-bit applications in IIS

Hi everyone,

When I set Enable 32 bit Applications in Application Pool of IIS, I have the following error:

HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.
There is malformed XML in the applicationhost.config or web.config file.
The server cannot access the applicationhost.config or web.config file because of incorrect NTFS permissions.

Any suggestions would be greatly appreciated!

windows-server-iis
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

SamWu-MSFT avatar image
0 Votes"
SamWu-MSFT answered

@Ben-2054

When I set Enable 32 bit Applications in Application Pool of IIS

If you disable enable 32-bit applications and it works, then your problem is running 32-bit applications on a 64-bit computer,

The server cannot access the applicationhost.config or web.config file because of incorrect NTFS permissions.

Please check what are set for Application Pool Identity.

More information you can refer to this link: HTTP Error 500.19 - internal server error when you open an IIS Webpage


If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.