question

NaitikKyada-4638 avatar image
0 Votes"
NaitikKyada-4638 asked CaseyYangMSFT-4714 commented

Edit Button Not Displaying on Modern Sites SharePoint 2019 on Premise

Hello,

modern sites on my site collection do not have a working edit button. The issue is inconsistent, Previously it was working but from last couple of days Edit button is not showing.

  1. I have full control over the entire collection, so permissions shouldn't be the issue.

  2. I tried multiple browsers, windows clearing the browser cache, and have determined that it's universally affecting all users regardless of browser.

  3. Tried to add "?ToolPaneView=2&Mode=Edit" to the url to check whether they could be edited still it's not working.

  4. I can confirm that these sites were editable a couple of days ago, After, Did R&D on that i came across to know that i need to install latest Sharepoint updates.
    So i updated kb5002135 to kb5002180 though it is not visible.

  5. Run the SharePoint configuration wizard but still same issue.

Before : 197291-image.png


After :

197213-image.png


office-sharepoint-server-administrationoffice-sharepoint-server-developmentsharepoint-dev
image.png (15.1 KiB)
image.png (34.9 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @NaitikKyada-4638,

Thank you for your question. We will give you an update as soon as possible. Thank you for your understanding and support.

0 Votes 0 ·

1 Answer

CaseyYangMSFT-4714 avatar image
0 Votes"
CaseyYangMSFT-4714 answered CaseyYangMSFT-4714 commented

Hi @NaitikKyada-4638,

Per my research, i didn't find any other useful information about this issue. Most of the similar thread they solved this issue by updating the SharePoint 2019 to the latest patch. You could update SharePoint Server 2019 MUI/language patch to KB 5002164 as you only updated SharePoint Server 2019 from kb5002135 to kb5002180.

For Reference: Edit Button Not Displaying on Some Modern Sites SharePoint 2019 on Premise


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hey,
We have Installed latest Patches and followed the below steps :

Installed Latest Updates.
Ran PS Config multiple times
Issue is with all site collections as well if we create new one.
Mount/Dismout database
Added "?ToolPaneView=2&Mode=Edit" to the url

0 Votes 0 ·

For reference i attached image here:

Latest Patches : 197795-image.png


Latest version of microsoft patches : 197817-image.png



As you can see we have Updated latest versions.

0 Votes 0 ·
image.png (11.2 KiB)
image.png (57.2 KiB)

Hi @NaitikKyada-4638,

Per my test, i am not able to reproduce this issue. I would suggest you open a ticket with Microsoft for further help.

0 Votes 0 ·