question

DenisPasternak-3587 avatar image
0 Votes"
DenisPasternak-3587 asked DenisPasternak-3587 commented

Migration to o365 failure: MapiExceptionNoAccess: MapiExceptionNoAccess: Unable to open message store. ‎(hr=0x80070005, ec=-2147024891)‎

Hello,

the organization has two 2010 Exchange servers with the latest updates. I needed to set up hybrid work and do a mailbox migration. Since Exchange 2010 is installed on a legacy Windows 2008 OS, I made the decision to add Windows 2016 with Exchange 2016 to complete the Hybrid Configuration Wizard.

First, I installed the AD Connector and performed a successful sync on one of the domain controllers. In the course of setting up hybrid operation, I chose one from Exchange 2010 that was accessible from the external network. The setup was successful. However, during the test user migration, I got an error.

User status
Data migrated:
Migration rate:
Last successful sync date:
Error: MapiExceptionNoAccess: MapiExceptionNoAccess: Unable to open message store. ‎(hr=0x80070005, ec=-2147024891)‎ Diagnostic context: Lid: 55847 EMSMDBPOOL.EcPoolSessionDoRpc called [length=223] Lid: 43559 EMSMDBPOOL.EcPoolSessionDoRpc returned [ec=0x0][length=288][latency=2] Lid: 23226 --- ROP Parse Start --- Lid: 27962 ROP: ropLogon [254] Lid: 17082 ROP Error: 0x80070005 Lid: 26937 Lid: 21921 StoreEc: 0x80070005 Lid: 27962 ROP: ropExtendedError [250] Lid: 1494 ---- Remote Context Beg ---- Lid: 45112 StoreEc: 0x80070005 Lid: 56872 dwParam: 0xFE Lid: 42712 StoreEc: 0x80070005 Lid: 45434 Unknown record layout: 00000008 Lid: 10786 dwParam: 0x0 Msg: 15.01.2242.004:VM--MFEXCH01:0b5371fd-241d-49a5-86a0-64d60a9f90b0 Lid: 1750 ---- Remote Context End ---- Lid: 26849 Lid: 21817 ROP Failure: 0x80070005 Lid: 26297 Lid: 16585 StoreEc: 0x80070005 Lid: 32441 Lid: 1706 StoreEc: 0x80070005 Lid: 24761 Lid: 20665 StoreEc: 0x80070005 Lid: 25785 Lid: 29881 StoreEc: 0x80070005

I did not find any information about this error, perhaps this problem is due to the fact that the user was created on Exchange 2016 and its database is located on Exchange 2016.


I would be grateful if you could help me with this problem.

I also wanted to ask. If I decommission Exchange 2016, I won't affect the hybrid configuration in any way. After all, it is configured for Exchange 2010.
Exchange 2016 was only used as a tool for hybrid setup.

office-exchange-server-administrationoffice-exchange-online-itprooffice-exchange-hybrid-itprooffice-exchange-server-itpro
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@DenisPasternak-3587
I am writing here to confirm with you any update about this thread now.
If the suggestion below helps, please feel free to accept it as an answer to help more people.

0 Votes 0 ·
KyleXu-MSFT avatar image
0 Votes"
KyleXu-MSFT answered DenisPasternak-3587 commented

@DenisPasternak-3587

About this issue, I would suggest you take the steps below to help us narrow it down:

  1. Create two new mailboxes, one hosted on Exchange 2010, the another hosted on Exchange 2016.

  2. Try to migrate them to Exchange online, check whether could migrate successfully.

In a coexist environment with Exchange 2010 and Exchange 2016, we need to use Exchange 2016 as the Internet facing server. Because request could proxy from Exchange 2016 to Exchange 2010, but not vice versa.

I also wanted to ask. If I decommission Exchange 2016, I won't affect the hybrid configuration in any way. After all, it is configured for Exchange 2010.

Yes, you could uninstall Exchange 2016, it doesn't affect the hybrid configuration. But, it is still suggested to rerun HCW after uninstalling Exchange 2016.

Personally, if need to choose one Exchange on-premises for management, I would choose Exchange 2016, because it is safer than Exchange 2010. EAC is more convenient to use than EMC.


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

The reason for the problem was that the mailbox was not located on Exchange 2010

0 Votes 0 ·
imamitsingh avatar image
0 Votes"
imamitsingh answered

This means that your port forwarding/firewall rules are not correctly configured. You need to send the traffic to 2016 internal IP and NOT to 2010 internal IP.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.