question

GhislainGOUBIN-1209 avatar image
0 Votes"
GhislainGOUBIN-1209 asked MayankBargali-MSFT edited

Microsoft forms responses are not available in logic app workflow

Hello,

I have a small issue with Microsoft Flow integration in Logic App, I created a small workflow to retrieve the response details from a MS Form into an Azure Automation runbook.

I have a first task "when a new response is submitted" followed by a "Get response details" with the "list of response details notifications ID", then I created my Azure Automation task but the dynamic content doesn't display the form responses.

I tested it with power automate and email sending, and I do have all the responses.

Thank you in advance for your help,
Regards,

azure-logic-apps
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @GhislainGOUBIN-1209 ,
What is the role "Azure Automation task" on your solution. If you use "when a new response is submitted" in power automate or logic app, the trigger will be the form submission. I just tested on logic apps as you described and it worked for me after I fill the form and submit it.

0 Votes 0 ·

Hi @BrunoLucas-9843 ,

I did try after a form was submitted and I still don't have the forms fileds available in my worflow as a dynamic content (I also tried with other actions).

My automation task is an hybrid worflow taking in parameters the form answers to create a new AD user.

From my understanding as an intermediary step I need the "get the response details" between the Automation task and "when a new response is submitted".

Could it be a limitation related to the Azure subscription plan ? Additionnaly, I don't have any warnings displayed in my logic app.

0 Votes 0 ·

1 Answer

BrunoLucas-9843 avatar image
0 Votes"
BrunoLucas-9843 answered BrunoLucas-9843 commented

Hi @GhislainGOUBIN-1209

I will write it here to show some screenshots

but first interesting detail, when I drag the "When a new response is submitted", I sign to it with the credentials from an office account from a different azure tenant:

198513-image.png

Next I have the "Get Response Details " where I select the form name and the response id:

198503-image.png

I had to use the trick of first switching to "expression", using the string cast , put the cursor between parentheses ,and switch back to "dynamic content" to be able to click on "list of response notifications response id". not sure if that is the best approach but worked to proof of concept. being a list may need an expression to handle array case there is more than one

198467-image.png

Using a compose to verify, I can now see the form content:

198468-image.png

Checking the execution plan, I can see the form input:

198439-image.png



image.png (18.1 KiB)
image.png (18.6 KiB)
image.png (40.1 KiB)
image.png (50.7 KiB)
image.png (40.1 KiB)
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @BrunoLucas-9843 ,

Thank your for your reply and your time.

Ok, I completely recreated the worflow and I reconnected to my account to re-sync the form and now see the forms submission correctly.

It seemed to be a sync error between logic App / MS Forms.

Thanks a lot, have a nice day !

1 Vote 1 ·
BrunoLucas-9843 avatar image BrunoLucas-9843 GhislainGOUBIN-1209 ·

Do you get to see the "response id: under the execution plan?
198440-image.png


0 Votes 0 ·
image.png (23.9 KiB)
BrunoLucas-9843 avatar image BrunoLucas-9843 GhislainGOUBIN-1209 ·

That was going to be my next advice, try to recreate the flow :-)
Glad you got it sorted.

0 Votes 0 ·