question

JulianSymonsFTG avatar image
0 Votes"
JulianSymonsFTG asked MarileeTurscak-MSFT commented

Error when configuring password writeback in AD Connect

Have been trying to get Password writeback working in Azure AD Connect but its failing to configure. I have followed all the steps as per the microsoft article -

https://docs.microsoft.com/en-us/azure/active-directory/authentication/tutorial-enable-sspr-writeback

I have attached the event logs I get when installing in text format

I have also followed the troubleshooting steps as per - https://docs.microsoft.com/en-gb/azure/active-directory/authentication/troubleshoot-sspr-writeback?WT.mc_id=Portal-Microsoft_Azure_Support

azure-ad-connectazure-ad-sspr
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

MarileeTurscak-MSFT avatar image
1 Vote"
MarileeTurscak-MSFT answered MarileeTurscak-MSFT commented

Hi @JulianSymonsFTGITMGR-3282 ,

Thank you for sharing the event logs!

I notice that you are receiving the following error:

 The client and server cannot communicate, because they do not possess a common algorithm.

According to several sources, this error can occur if you have not enabled either TLS 1.2 or 1.3 on the Azure AD Connect server, OR if you have not updated windows to support that version of TLS.

You need to enable TLS 1.2 in both the schannel regkeys and the .netframework regkeys, and if you just enable it in one you may still run into this issue when enabling SSPR. (See related discussion.)

Let me know if you have further questions!



If the information provided was helpful to you, please mark the thread as answer so that others in the community searching for similar information can more easily find a solution.


· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thank you! Was an issue with the RegKeys not being present for Schannel/.Net

1 Vote 1 ·

Thanks for confirming!

0 Votes 0 ·