question

BBirdsell avatar image
BBirdsell asked ·

Azure VM-hosted JupyterLab networking config help

I'm worked my way through Quickstart: Set up the Data Science Virtual Machine for Linux (Ubuntu) which is deceptively simple, and am running into a network config problem that is not referenced on the page.

2646-inboundportrules.png

I've confirmed I have Data Science Virtual Machine- Ubuntu 18.04 Preview running on a virtual machine. However, once
set up is completed it will sometimes take me into the signin and next the server spinup page. However, it never redirects as stated on the page. Instead it lags and starts to return in the browser the below displayed errors for the links suggested in the Quickguide. (Hub above. Labs lower.) Changing the inbound port rules to above helped but it still won't ever bring be to Jupyterlab's home screen. Is a certain tier of Azure required? I'm on the lowest since I'm just learning how to set one of these up, but I do have a team interested in using the server. Maybe it's a problem with the virtual network and how my components are talking to each other?

Does anyone have any suggestions on how I can fix this problem? I'm on OS10.14.6 and Chrome 80.0.3987.87

2698-jupytererrors.png


UPDATE 02/11/2020
When I scan the public IP with Telnet on the MacOS I get the following. Looks ok to me.

 Open TCP Port:     8000           irdmi


[1]: https://docs.microsoft.com/en-us/azure/machine-learning/data-science-virtual-machine/dsvm-ubuntu-intro


azure-virtual-machinesazure-virtual-machines-networking
jupytererrors.png (318.2 KiB)
5 comments
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Can you try to telnet with the PublicIP:8000 and check if you are able to connect ?

0 Votes 0 · ·

Is there any update?

0 Votes 0 · ·

I updated the post. Telnet does see an open TCP port..

0 Votes 0 · ·

What is the URL that you are trying to browse? It has to be https://IP:port

It port 8000 is open, then based on the screenshot you posted, it seems like the service takes more time to respond to your request. Can you try this URL ? https://your-vm-ip:8000/user/your-username/lab and let me know if you are able to log in ?

0 Votes 0 · ·
Show more comments

1 Answer

msrini-MSFT avatar image
msrini-MSFT answered ·

Hi,

I tried to repro by deploying a new Data Science Ubuntu VM and I am able to access the site with https://ip:8000 and I am able to see the Login prompt as shown in documentation. Can you try to delete the VM and create a new one again ? Also make sure that you choose Password for SSH instead of the Public key.

3 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I will try again. However, the three previous times I attempted this quick guide I made sure to select password for the Jupyter server instead of SSH and selected an all lowercase username. I wanted to set up the machine on the lowest tier before scaling the VM for a couple of project members. Do you think the tier of service has any effect? Did you attempt the quick guide on the lowest Azure tier?

0 Votes 0 · ·

So for the 4th time I recreated a DSVM from the quick start guide noted in the OP. I made sure to select the correct lowercase user name etc. recorded in the quick guide. This time I also used a different higher tier VM "B1ms Standard General purpose" but unfortunately must report that both https://ip:8000 and https://your-vm-ip:8000/user/your-username/lab failed to load with the same errors as noted above. What ways are there to keep troubleshooting this?

0 Votes 0 · ·

Is your VM behind Load balancer? Can you make sure you are trying to use the IP which is associated to the NIC?

0 Votes 0 · ·