question

charin-1444 avatar image
1 Vote"
charin-1444 asked LanceMoore-2002 published

SSMS18.6: microsoft.sqlserver.management.iregistrationservice not found

service 'microsoft.sqlserver.management.iregistrationservice' not found (microsoft.sqlserver.management.sdk.sqlstudio)

I found the error above when I try to connect database engine with SQL Server Authentication. It shows the error but everything seems fine, I think it may cause of trouble later. I try to fix that with many solutions, but it still doesn't work at all. (re-installed SSMS and SQL Server, repaired both)

So, I checked to C:\Program Files\Microsoft SQL Server\150\Tools\Binn and I can't find ManagementStudio folder. I think this will be the cause of this problem but I don't know how to fix that.

Please, give me some advice. Thank you so much.

P.S. I use Microsoft SQL Server 2019 version 15.0.4013.40

sql-server-general
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

GuoxiongYuan-7218 avatar image
0 Votes"
GuoxiongYuan-7218 answered charin-1444 commented

C:\Program Files (x86)\Microsoft SQL Server\150\Tools\Binn\ManagementStudio

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

It doesn't have ManagementStudio folder either

0 Votes 0 ·
MiaMiao-MSFT avatar image
2 Votes"
MiaMiao-MSFT answered MiaMiao-MSFT edited

Hi @charin-1444,

Solution:
Try to run SSMS as Administrator.

And SSMS 18.6.exe:
Default Path: C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\Ssms.exe
23858-ssmsexe.jpg

BR,
Mia


If the answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



ssmsexe.jpg (124.4 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MiaMiao-MSFT avatar image
0 Votes"
MiaMiao-MSFT answered MiaMiao-MSFT commented

Hi @charin-1444,

Is the reply helpful?

BR,
Mia

If the answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

It's still the same problem. I try to re-installed and repaired SSMS and Microsoft SQL Server 2019 many times but nothing happened.24394-messageimage-1600068056379.jpg


0 Votes 0 ·

Do you try to run it as Administrator?

0 Votes 0 ·
charin-1444 avatar image
2 Votes"
charin-1444 answered omkarsawant-7233 published

it's work now. I just select custom report... in SSMS. So, it restarts itself automatically. Then, it's work! I'm still so confused. but, if have the same problem again. I will comment on this thread.

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I swear. This worked for me to, it restarted SSMS and then no more errors. Wow MS?

0 Votes 0 ·

@charin-1444 where to find custom report ?

0 Votes 0 ·
WeezyBored-6485 avatar image
4 Votes"
WeezyBored-6485 answered LanceMoore-2002 published

This SSMS issue is very common since Microsoft implemented the Ransomware Protection in Windows. It is not an installation issue: you don't need to repair or reinstall SSMS. You don't need to run SSMS "as an administrator," either. SSMS needs to create/access a sub-folder "SQL Server Management Studio" in your profile Documents folder, so it is a permissions issue: something is blocking SSMS.exe from accessing your profile Documents folder. Most likely cause is the new Windows Ransomware Protection of your profile folders. The easiest fix is to disable Ransomware Protection in Windows. The next easier fix is to manually add the required "SQL Server Management Studio" sub-folder to your profile Documents folder ;)

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thank you!

I would think (oh, wait) that MS would update their own product to take this into account!

0 Votes 0 ·

I want to hug you big. thank you

0 Votes 0 ·

Worked right away. Thanks for the tip!

0 Votes 0 ·
FredyNesch-3244 avatar image
2 Votes"
FredyNesch-3244 answered Frossi-4182 commented

I had the same issue. Just go the the program folder of SSMS C:\Program Files (x86)\Microsoft SQL Server Management Studio 18 and remove the write protection of this folder and all subfolders. ;)

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

C:\Program Files (x86)\Microsoft SQL Server Management Studio 18
Then right-click on the folder, properties, security and select your profile, then edit, and finally Full control. Apply the changes and that's it, it worked for me.

0 Votes 0 ·