question

Alex-7989 avatar image
0 Votes"
Alex-7989 asked ·

Unable to log into Azure AD joined VM with Role assigned Admin

Hi,
I've stood up my first VM with the preview management options enabled to allow AAD accounts to login. But when I try to connect with the UPN that has the admin role assigned, I get "WE ARE UNABLE TO CONNECT RIGHT NOW, PLEASE CHECK YOUR NETWORK AND TRY AGAIN LATER".
Here are some factors:
--We do NOT have MFA required
--The host name shows "enabled" in the AAD devices
--The windows 10 workstation I'm using shows "enabled" in the AAD devices
--I am able to login with the local admin account
-- I get 200's when I run the curl commands recomended here: https://docs.microsoft.com/en-us/azure/active-directory/devices/howto-vm-sign-in-azure-ad-windows
-- looks like the version of the AAD agent that got installed is 0.4.1.1
-- I've tried AzureAD\first.last@domain.com, first.last@domain.com, UPN, SPN.

I know that this feature is in preview, but this would REALLY help us use Azure in a Production perspective to stay compliant.

azure-ad-authenticationazure-ad-tenant
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

alfredorevilla-msft avatar image
0 Votes"
alfredorevilla-msft answered ·

The device from where you're connecting must be a Windows 10 PC that is Azure AD joined or hybrid Azure AD joined to the same directory as the VM. If that's the case then open a support request.


Please let us know if this answer was helpful to you. If so, please remember to mark it as the answer so that others in the community with similar questions can more easily find a solution.



· 1 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@Alex-7989
I just wanted to check in and see if you required additional assistance or if you were able to resolve this issue?


If any reply/answer helped resolve your question, please remember to "mark as answer" so that others in the community facing similar issues can easily find the solution.

0 Votes 0 ·