question

Pronizius avatar image
0 Votes"
Pronizius asked XuyanDingMSFT-4872 edited

SharePoint Subscription Edition - Add Image to modern page not working

We are running SharePoint Subscription Edition with the newest CU.
It is not possible to add an image to a modern page
1 Add image:
227503-1.png

2 No prompt or anything to choose a picture
227464-2.png

3 When I click on the edit icon, I get a white empty side panel
227512-3.png

4 With the developer tools i get the following errors:
227460-4.png
227446-5.png


I can add the Pnp Modern Script Editor to add pictures to pages, but this can't be a solution for normal users.


Edit: I forget to remove some main url parts from the screenshots, that's why I was editing the question.

sharepoint-devoffice-sharepoint-server-developmentoffice-sharepoint-server-customizationoffice-sharepoint-server-itpro
1.png (16.7 KiB)
2.png (14.4 KiB)
3.png (17.7 KiB)
4.png (40.8 KiB)
5.png (99.0 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

XuyanDingMSFT-4872 avatar image
1 Vote"
XuyanDingMSFT-4872 answered XuyanDingMSFT-4872 edited

Hi @Pronizius,

I'm glad to hear you solve the problem ,if you have any issue about SharePoint, you are welcome to raise a ticket in this forum.

By the way, since the Microsoft Q&A community has a policy that "The question author cannot accept their own answer. They can only accept answers by others.". and according to the scenario introduced here: Answering your own questions on Microsoft Q&A, I would make a brief summary of this thread:

Issue Symptom:
SharePoint Subscription Edition - Add Image to modern page not working

Solution:
By Pronizius:
To all who have problems with missing navigation or not working image webparts (as of CU July 2022), check that you always installed BOTH language dependent and independent updates. Because we skipped the June Update, we overlooked the second language dependent fix KB 5002225.
July-2022-cu-for-sharepoint-server-subscription-edition-is-available-for-download
229868-image.png


You could click the "Accept Answer" button for this summary to close this thread, and this can make it easier for other community member's to see the useful information when reading this thread. Thanks for your understanding!


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



image.png (13.4 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

XuyanDingMSFT-4872 avatar image
0 Votes"
XuyanDingMSFT-4872 answered XuyanDingMSFT-4872 commented

Hi @Pronizius,

Since we can't reproduce your situation, we need to narrow down the problem and try some things.

1.For errors that failed to load chunks, you could try clearing the browser cache and restarting it.

2.Try using a different browser or your browser's InPrivate mode to see if the same error occurs.

3.Are other users with permissions facing the same problem? View through another computer or account.

4.May I know if all SharePoint pages have the same problem? You could create a new SharePoint page to check.

5.Check if the same issue occurs with other SharePoint sites.


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @XuyanDingMSFT-4872

thanks for the response and that you tried to reproduce it.

I special tried now different site collections and different browsers (edge, chrome, ie and firefox), I also tried InPrivate with some browsers and different users and permissions.
Also i tried another computer from a colleague which did not access our new SharePoint ever.
Lastly, I create a new Web Application, because I already have a few SPFx solutions, just to be sure, that they do not cause the error.

But no change, always the same issue.

I did not check this before, but we actually do NOT have the "111.sp-imageeditcontrol.js" file on our front end server:
227429-6.png

Or is the path another?
There is a "112..sp-imageeditcontrol.js" if I copy it and rename it to "111.sp-imageeditcontrol.js" and do a iisreset, it is still not working, but I don't get the js error anymore.


0 Votes 0 ·
6.png (37.7 KiB)

Hi @XuyanDingMSFT-4872

Update:
I don't know how I could miss this, but I just recognized that the whole left navigation including the searchbox is missing on modern pages. Even on the newly created web application:
227753-7.png
On the content page it is still working, so only modern pages seem to be affected:
227696-8.png

This for sure still was working before the CU. Could all theseissues be connected with the latest CU?
We installed / get the info of the new CU here:
july-2022-cu-for-sharepoint-server-subscription-edition-is-available-for-download


0 Votes 0 ·
7.png (13.9 KiB)
8.png (40.1 KiB)

Hi @Pronizius ,

Thanks for the update! Due to the limitations of our laboratory environment, we cannot install the latest CU temporarily to see if such a problem occurs. I suggest you uninstall the latest CU to see if the modern pages will be restored to the state where there was no problem before. If it can be restored to a state without problems, do not update the CU for the time being until the next patch update, when I will report the problem to Microsoft. If uninstalling still doesn't resolve it, a thorough investigation of your environment may be required. In view of the difficulty of timely troubleshooting in the form of forums, it is recommended to open a ticket to obtain better service in such a case, and let Microsoft engineers conduct more in-depth research. Thank you for your understanding!

1 Vote 1 ·
Pronizius avatar image Pronizius XuyanDingMSFT-4872 ·

Hi @XuyanDingMSFT-4872

thanks for the quick feedback.
We are only planning to migrate to the Subscription Edition next year. Right now we are migrating our development system and farm solutions / developing new spfx solutions. So there is currently no time pressure. We can not uninstall our CU anymore and I think we will just wait for the next CU and hope it will fix these issues.
Thank you very much for reporting the problem to Microsoft.
If no solution will come till we go live, we will of course create a Microsoft support ticket.

Just one more question and one update:
Is it normal that the javascript file "111.sp-imageeditcontrol.js" is missing on our front end server?

And the update:
Here the errors which I assume come from the missing left navigation and search box. Also here another js is missing:
228087-9.png
228094-10.png


0 Votes 0 ·
9.png (144.8 KiB)
10.png (29.1 KiB)
Show more comments
Pronizius avatar image
0 Votes"
Pronizius answered

Dear all,

To all who have problems with missing navigation or not working image webparts (as of CU July 2022), check that you always installed BOTH language dependent and independent updates.

Because we skipped the June Update, we overlooked the second language dependent fix KB 5002225.

I also recommend, always reading very carefully the messages from Stefan Goßner:
july-2022-cu-for-sharepoint-server-subscription-edition-is-available-for-download

Important: It is required to install both fixes (language dependent and independent) to fully patch a SharePoint server. This applies also to servers which do not have language packs installed. The reason is that each SharePoint installation includes a language dependent component together with a language independent component. If additional language packs are added later (only) the language dependent fix has to be applied again.

Unfortunately, we missed it.

@XuyanDingMSFT-4872 thank you very much for the reply and help.

Best regards




5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.