question

AndrewFoulk-0025 avatar image
0 Votes"
AndrewFoulk-0025 asked azure-cxp-api edited

Visual Studio login will not accept my Authenticator's Code

Using 16.7.3 Visual Studio 2019
Visual Studio keeps telling me to ReEnter Credentials, but every time to complete this I must enter my Authenticator Mobile App code, which I do and it tells me that is not the code it is expecting. It offers to try another method, offering to send a notification to the mobile app, but I never receive a notification.

I already changed the account setting to using the system browser and not the embedded browser, but same result.

How can I get the login to finally work so I can properly connect to my Cloud explorer and other stuff? (this also includes being able to even try a "Report a Problem" through Visual Studio, which tells me I'm not signed in)

azure-ad-multi-factor-authenticationazure-ad-authentication
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@AndrewFoulk-0025
I just wanted to check in and see if you required additional assistance or if you were able to resolve this issue?


If any reply/answer helped resolve your question, please remember to "mark as answer" so that others in the community facing similar issues can easily find the solution.

0 Votes 0 ·

Hi James,
I'm not 100% certain how the login part went away for me, it may have been after I entered SQL Server Admin Credentials when working on an AAS Tabular Model, or it may have cleared up after the VS update 16.7.3 last week. Whatever the issue was, seems to be gone now. I can use Cloud Explorer and SQL Server Object Explorer without it telling me to re-enter credentials.

Thank you for checking back in on this issue!

1 Vote 1 ·

1 Answer

DSPatrick avatar image
0 Votes"
DSPatrick answered

Try using the Open Get Help app here, and you'll eventually get to chat with microsoft account support.
https://support.microsoft.com/en-us/contactus/

The microsoft authenticator app is not supported here on QnA. I'd try asking for help in dedicated forum here.
https://social.technet.microsoft.com/Forums/en-US/home?forum=MicrosoftAuthenticatorApp

--please don't forget to Accept as answer if the reply is helpful--




5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.