question

ISAACORTIZ-6850 avatar image
0 Votes"
ISAACORTIZ-6850 asked ·

AzureDevOps Build is Not Compiling DLLs

With XAML builds you could add the following argument /p:GenerateProjectSpecificOutputFolder=True and it would cleanly build your code and compile your dlls per library. With YAML builds however, this argument does not appear to work and all the code comes out uncompiled with *.vb files. My solution has a mix of class, web, and console apps. Any recommendations on getting it to properly build? Many thanks!

azure-webapps
· 1
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

The behavior you are describing with that command switch has been the default for all the build systems after the xaml systems. If you use the task based build system and add a task for MSBuild or Vsual Studio build, do the logs report compilation success? That would tell if its an issue with the YAML build/definition or the projects.

1 Vote 1 ·
PiyushMutha avatar image
0 Votes"
PiyushMutha answered ·

Please try to check the “Build Action” property of that .vb file. It should be “Compile”.

  1. Right click the .vb file in Solution Explorer, and then select “Properties”.

  2. Select “Compile” option of the “Build Action” property in Properties panel.

  3. Rebuild you project and test again.


· 2 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

OP is not talking about building on the local machine

0 Votes 0 ·

The vb files are all currently set to compile by default and it's still building uncompiled. :(

0 Votes 0 ·
StingyJack avatar image
0 Votes"
StingyJack answered ·

You should enable the system.debug == true variable and check the "Enable System Diagnostics" for a build, run the build, and then inspect the logs for it. The actual msbuild.exe command that is executed will be in there, with all the parameters its using.

Clean all of the bin and obj folders in your solution, and then take the command from the build log and and try running it locally to see if you get output.

Chances are that you will see the same as the build agent is seeing, and have probably not named the correct solution configuration (Debug, Release) or something simple like that.

If you didnt find an msbuild command in the logs then you have to fix the build definition to add it. Try creating a new build definition using the Task based engine and not the YAML way. YAML builds are newer and probably a bit buggy.

·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.