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Thanks Sadiqh!

At last I got this working. The clue was in the MARS agent log file on the Hyper-V host: CBEngineCurr.errlog

https://pod01-prot2.we.backup.windowsazure.com/ProtectionService.svc that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details. ---> System.Net.WebException: The remote server returned an error: (407) Proxy Authentication Required.

I had to create an exception in the proxy server that bypassed authentication for backup.windowsazure.com.

Also, even though the MARS agent asks you if you have a proxy server, DO NOT USE IT!
When you install the MARS agent, choose the option "Connect directly to Azure Site Recovery without a proxy server".
If you choose "Connect using a proxy server" then the agent tries to connect via HTTPS which is not supported by Azure.

Almost 1 month later, and Microsoft support still do not have a clue what Error Code '8079ffff' means.
I have been escalated to a clustering expert, they think it has to do with our cluster setup.
I have a feeling it is to do with using ExpressRoute from our LAN to Azure, but that's just a guess.
If there is any resolution I will post an update.
Richard.

Microsoft closed the case because I was on holiday for 2 weeks. Now they don't answer when I ask them to re-open the case.
Case still not solved; all suggestions from the support team do not work.
I have to make a new case for Microsoft.

:-<

Azure support sucks.


Some more information....

Microsoft support say I need to use version 5.1.7029.0 of the Azure Site Recovery Provider, not 5.1.7030 like installed.

But when I download version 5.1.7029 from Microsoft and install it, i see version 5.1.7030 in the program files! Even when I delete the registry key, or install on a different server without the Azure Site Recovery Provider already installed, Seems like a bug in the agent to me.


https://download.microsoft.com/download/a/3/3/a339c231-5c62-4c44-aa7c-f449c3168f07/AzureSiteRecoveryProvider.exe

It says version 5.1.7029.0, in the Properties/Details, but when you install it, it says 5.1.7030 in the Program Files!!!! Crazy.


Hi Sadiqh, no the issue is not resolved, every tine I install version 5.1.7029.0 it shows as version 5.1.7030, which MS Support say is not a supported version. Doesn't matter where i install it, always shows the wrong version number.

The support engineer is currently discussing internally.

TrackingID#2111290050000968

Regards
Richard.

We do have a proxy server but I can't see anything blocked on that end, coming from Hyper-V server.


Thanks @LimitlessTechnology-2700 .
1. Done (difficult without a valid support ticket!)
2. Ok, I don't see any difference but OK.
3. There are no checkpoints on this VM
4. OK, done

Same problem:

Error ID
70094
Error Message
Protection couldn't be enabled for the virtual machine.
Provider error
Provider error code: 31343

Provider error message:
The operation failed with the error: Enable replication failed for virtual machine '<NAME>'. Service returned an error. (Error Code '8079ffff').

Provider error possible causes:
Failure while replicating the virtual machine to Azure.

Provider error recommended action:
Check Microsoft Azure Recovery services event viewer logs on the Hyper-V host and resolve any errors.
Possible causes
Protection can't be enabled with the virtual machine in its current state. Check the Provider errors for more information.


Same error in the Event Log in the Hyper-V host:

Enable replication failed for virtual machine '<NAME>'. Service returned an error. (Error Code '8079ffff').

OK, now the VM is switched on, I get a different error:

Error ID
70094

Error Message
Protection couldn't be enabled for the virtual machine.

Provider error
Provider error code: 31389

Provider error message:
Job 'Enabling Replication' (xxxxxx) failed. Job State Exception. Error Code: 32768. ErrorSummaryDescription: Hyper-V failed to enable replication.. ErrorDescription: .

Provider error possible causes:
Check the error details.

Provider error recommended action:
Resolve the issue and try again.
Possible causes
Protection can't be enabled with the virtual machine in its current state. Check the Provider errors for more information.


On the Hyper-V server it still says the same error message in EventViewer:
Enable replication failed for virtual machine '<NAME>'. Service returned an error. (Error Code '8079ffff').


Some more information...

I already tried another suggestion: "Renew Certificates" for the Hyper-V host. This had no effect.

VM is a Generation 2 VM, with no checkpoints.

Hyper-V is Windows Server 2016 Datacenter with .NET Framework 4.6.2 installed

The VM is switched off; does this make any difference to replication? I can't find anywhere if it says the VM has to be switched on.

Secure boot off.

Updated the Configuration Version, did all the pending Windows Updates... reboot again...

Error Message
Protection couldn't be enabled for the virtual machine.

Provider error
Provider error code: 31343

Provider error message:
The operation failed with the error: Enable replication failed for virtual machine '<NAME>' due to a network communication failure.