P2V and Other Jobs Fail with Error 2912, 0x8007xxxx

A common problem during data transfers, especially toward the end of P2V jobs, is Error 2912, with some variation of 0x8007xxxx. This is generally certificate related. I’ve put together a complete set of steps that will correct certificate issues between the SCVMM Server and Hosts. Why do certificates matter? BITS uses them… and BITS is what transfers data.

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Something to keep in mind regarding P2V jobs specifically. Check Tasks that are running under the current P2V Job and you will see something similar to that below. Notice that ‘Deploy file (using LAN)’ appears to have succeeded. BITS is then no longer needed, right? Not exactly. At this point the newly created VHD of the C: drive for the system you just converted is mounted on the Destination Host. BITS is now used again as the SYSTEM registry hive is pulled from this mounted VHD, and copied to the SCVMM Server for fix up (setting things to properly boot in a virtual environment). In this case the certificates between the SCVMM Server and the Destination Host are not good.

Use the directions in the article below to correct all certificates, then start a new P2V job. It should work.

P2V fails with Error 2912 0x80072F0C with System Center Virtual Machine Manager 2008 or System Center Virtual Machine Manager 2008 R2

SYMPTOMS

When using System Center Virtual Machine Manager (SCVMM) to perform a Physical to Virtual (P2V) conversion, the job fails at 60% with the following error:
Error (2912)
An internal error has occurred trying to contact an agent on the vmmserver.contoso.com server.
Recommended Action
Ensure the agent is installed and running. Ensure the WS-Management service is installed and running, then restart the agent.

CAUSE

During the 'Make operating system virtualizable' step, files are copied from the destination host (the server that will host the virtualized system) to the SCVMM Server. This BITS operation fails due to a certificate problem as indicated by the error 0x80072F0C (ERROR_INTERNET_CLIENT_AUTH_CERT_NEEDED).

RESOLUTION

To resolve this issue, remove the managed host from the SCVMM server and also delete any residual certificates from the host on the VMM server, then re-add the host:

1.

On the SCVMM server, remove the managed host from the console. The steps on how to remove a managed host are outlined in the following TechNet article: https://technet.microsoft.com/en-us/library/cc956121.aspx (https://technet.microsoft.com/en-us/library/cc956121.aspx)

2.

Now we need to locate and delete any certificates for the Host computer.

3.

Open the Certificate console on the SCVMM server. a. Open a new mmc and add the certificates snap-in. b. Select the option of 'computer account' and 'local computer'. c. Select Finish and Ok to load the snap-in.

4.

The certificates for the Host computer can be in any of the following locations. a. Personal Certificates. b. Trusted People (if the host is W2K8 or W2K8 R2). c. Trusted Root Authorities (If the host is W2K3).

5.

In each store, expand the Friendly Name field and locate the certificate[s] for the Host server that have a Friendly Name starting with 'SCVMM_CERTIFICATE_KEY_CONTAINER' followed by either the FQDN / IP address / NetBIOS name of the Host server and delete them.

6.

Re-add the host in SCVMM which recreates the certificates as needed.

MORE INFORMATION

SCVMM uses BITS to transfer payload between SCVMM managed computers. These data transfers are encrypted by using a self-signed certificate generated at the time a host machine is added to SCVMM. If these certificates are missing or corrupted from the SCVMM server or managed computers, the payload deployment job can fail. Deleting the certificates and re-adding the host will cause the certificates to be regenerated. 

 

Link to the KB here
https://support.microsoft.com/default.aspx?scid=kb;en-US;2385280